problem with wpa_supplicant on windows XP, help me?

phamtienluc phamtienluc phamtienluc at yahoo.com
Wed Jan 25 19:52:40 EST 2006


Dear Mr Jouni!

I am in Viet Nam, I am using wpa_supplicant version
0.4.7, wincap 3.1, I want to run them  on windows XP
in plaintext (no wap, no encrypt, no authentication).
But not connnected. Please show me why????

My steps:
1 My wpa_supplicant.conf

# Plaintext (no encryption) network
ctrl_interface=/var/run/wpa_supplicant
network={
	ssid="default"
	scan_ssid=1
	key_mgmt=NONE
}

2. run ndis_event.exe

3. run win_if_list.exe

C:\WPA_test>win_if_list
ifname: \Device\NPF_GenericDialupAdapter
description: Generic dialup adapter
ifname:
\Device\NPF_{37577F39-416C-4B7E-9ECA-46B913DB967F}
description: Intel(R) PRO/Wireless 2200BG Network
Connection (Microsoft's Packet
 Scheduler)

4. run wpa_supplicant.exe as:

C:\WPA_test>wpa_supplicant
-i\Device\NPF_{37577F39-416C-4B7E-9ECA-46B913DB967F}
-c wpa_supplicant.conf -dd
Initializing interface
'\Device\NPF_{37577F39-416C-4B7E-9ECA-46B913DB967F}'
conf
 'wpa_supplicant.conf' driver 'default' ctrl_interface
'N/A'
Configuration file 'wpa_supplicant.conf' ->
'C:\WPA_test/wpa_supplicant.conf'
Reading configuration file
'C:\WPA_test/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
Line: 9 - start of a new network block
ssid - hexdump_ascii(len=7):
     64 65 66 61 75 6c 74                             
default
key_mgmt: 0x4
Priority group 0
   id=0 ssid='default'
Initializing interface (2)
'\Device\NPF_{37577F39-416C-4B7E-9ECA-46B913DB967F}'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
NDIS: Packet.dll version: 3, 1, 0, 27
NDIS: 2 adapter names found
NDIS: 2 adapter descriptions found
NDIS: 0 - \Device\NPF_GenericDialupAdapter - Generic
dialup adapter
NDIS: 1 -
\Device\NPF_{37577F39-416C-4B7E-9ECA-46B913DB967F} -
Intel(R) PRO/Wire
less 2200BG Network Connection (Microsoft's Packet
Scheduler)
NDIS: Adapter description prefix 'Intel'
ndis_get_oid: oid=0xd010122 len (512) failed
NDIS: verifying driver WPA capability
NDIS: WPA key management supported
NDIS: WPA-PSK key management supported
ndis_set_oid: oid=0xd01011b len (4) failed
NDIS: Failed to set OID_802_11_ENCRYPTION_STATUS (6)
NDIS: no WPA support found
NDIS: driver capabilities: key_mgmt 0x5 enc 0x0 auth
0x3
Own MAC address: 00:0e:35:c1:ba:d3
wpa_driver_ndis_set_wpa: enabled=1
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_set_oid: oid=0xd010114 len (4) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_set_oid: oid=0xd010114 len (4) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_set_oid: oid=0xd010114 len (4) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_set_oid: oid=0xd010114 len (4) failed
Setting scan request: 0 sec 100000 usec
Added interface
\Device\NPF_{37577F39-416C-4B7E-9ECA-46B913DB967F}
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
NDIS: turning radio on before the first scan
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
Scan timeout - try to get results
Scan results: 1
Selecting BSS from priority group 0
0: 00:30:4f:2e:7d:58 ssid='default' wpa_ie_len=0
rsn_ie_len=0 caps=0x0
   skip - no WPA/RSN IE
   selected non-WPA AP 00:30:4f:2e:7d:58
ssid='default'
Trying to associate with 00:30:4f:2e:7d:58
(SSID='default' freq=2462 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: clearing own WPA/RSN IE
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification -
portControl=ForceAuthorized
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
Authentication with 00:00:00:00:00:00 timed out.
Added BSSID 00:00:00:00:00:00 into blacklist
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 0 usec
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
Scan timeout - try to get results
Scan results: 1
Selecting BSS from priority group 0
0: 00:30:4f:2e:7d:58 ssid='default' wpa_ie_len=0
rsn_ie_len=0 caps=0x0
   skip - no WPA/RSN IE
   selected non-WPA AP 00:30:4f:2e:7d:58
ssid='default'
Trying to associate with 00:30:4f:2e:7d:58
(SSID='default' freq=2462 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: clearing own WPA/RSN IE
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification -
portControl=ForceAuthorized
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
Authentication with 00:00:00:00:00:00 timed out.
BSSID 00:00:00:00:00:00 blacklist count incremented to
2
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 0 usec
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
Scan timeout - try to get results
Scan results: 1
Selecting BSS from priority group 0
0: 00:30:4f:2e:7d:58 ssid='default' wpa_ie_len=0
rsn_ie_len=0 caps=0x0
   skip - no WPA/RSN IE
   selected non-WPA AP 00:30:4f:2e:7d:58
ssid='default'
Trying to associate with 00:30:4f:2e:7d:58
(SSID='default' freq=2462 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: clearing own WPA/RSN IE
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification -
portControl=ForceAuthorized
ndis_get_oid: oid=0xd010101 len (6) failed
ndis_get_oid: oid=0xd010101 len (6) failed
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface
\Device\NPF_{37577F39-416C-4B7E-9ECA-46B913DB967F}
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_ndis_set_wpa: enabled=0
No keys have been configured - skip key clearing
Removed BSSID 00:00:00:00:00:00 from blacklist (clear)
Cancelling scan request

Thank you very much!
Best Regards

Lucpt

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



More information about the HostAP mailing list