hostap prism 1.8.4 problems

Jason Carr jason at flacid.org
Wed Jan 11 00:00:45 EST 2006


I hate replying to myself, somebody hook me up with some information
please.

wpa_supplicant says this:

1136954962.451180: WPA: Group rekeying completed with 00:09:5b:2f:83:83
[GTK=TKIP]
1136955007.819411: CTRL-EVENT-EAP-STARTED EAP authentication started
1136955007.824420: CTRL-EVENT-EAP-METHOD EAP method 13 (TLS) selected
1136955007.947432: CTRL-EVENT-EAP-SUCCESS EAP authentication completed
successfully
1136955010.958831: CTRL-EVENT-DISCONNECTED - Disconnect event - remove
keys
1136955010.959207: CTRL-EVENT-DISCONNECTED - Disconnect event - remove
keys

hostap/kernel says:
Jan 10 23:57:18 [kernel] wifi0: STA 00:12:f0:34:60:7f TX rate lowered to
55
Jan 10 23:57:18 [kernel] wifi0: STA 00:12:f0:34:60:7f TX rate lowered to
20
Jan 10 23:57:18 [kernel] wifi0: STA 00:12:f0:34:60:7f TX rate lowered to
10
Jan 10 23:57:21 [kernel] wifi0: TXEXC - status=0x0004 ([Discon])
tx_control=000c
                - Last output repeated twice -
Jan 10 23:57:21 [kernel]    retry_count=0 tx_rate=110 fc=0x4208 (Data::0
FromDS)
Jan 10 23:57:21 [kernel]    A1=00:12:f0:34:60:7f A2=00:09:5b:2f:83:83
A3=00:09:5b:2f:83:83 A4=00:00:00:00:00:00

suck.


On Tue, 2006-01-10 at 23:11 -0500, Jason Carr wrote:
> Even more information, I get this in the kernel log when my machines
> deauthenticate for no reason:
> 
> ==> kernel/current <==
> Jan 10 23:06:47 [kernel] wifi0: STA 00:12:f0:34:60:7f TX rate lowered to
> 55
> Jan 10 23:06:47 [kernel] wifi0: STA 00:12:f0:34:60:7f TX rate lowered to
> 20
> Jan 10 23:06:47 [kernel] wifi0: STA 00:12:f0:34:60:7f TX rate lowered to
> 10
> 
> - Jason
> 
> On Tue, 2006-01-10 at 18:46 -0500, Jason Carr wrote:
> > The only reason I upgraded from 1.7.4 was because I would get
> > disconnected often and never be able to reconnect.  All of my clients
> > seem to get forcefully disconnected and never return :(  I usually had
> > to restart wpa_supplicant for them to reconnect.
> > 
> > Have you ever seen this problem before?  I'm using EAP-TLS.  PS...
> > Downgraded back to 1.7.4
> > 
> > - Jason
> > 
> > On Tue, 2006-01-10 at 22:55 +0100, Henrik Brix Andersen wrote:
> > > On Tue, Jan 10, 2006 at 02:09:21PM -0700, Kelly Hogan wrote:
> > > > We saw similar.  Downgraded to 1.8.2 and found stability again.
> > > 
> > > Same here - but I downgraded all the way to 1.7.4 to find stability
> > > with WPA.
> > > 
> > > Regards,
> > > Brix
> > > _______________________________________________
> > > HostAP mailing list
> > > HostAP at shmoo.com
> > > http://lists.shmoo.com/mailman/listinfo/hostap
> > _______________________________________________
> > HostAP mailing list
> > HostAP at shmoo.com
> > http://lists.shmoo.com/mailman/listinfo/hostap
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20060111/9f764462/attachment.pgp 


More information about the HostAP mailing list