PRISM2_NON_VOLATILE_DOWNLOAD in kernel 2.6.14

Jouni Malinen jkmaline at cc.hut.fi
Thu Jan 5 00:13:11 EST 2006


On Sat, Dec 31, 2005 at 12:39:54AM +0200, Jar wrote:

> Yes, but it still complains incompatibility with some cards that are 
> actually compatible. E.g. when I flash my old WL200. When somebody sees 
> such a warning I can understand why he decide to the updating with some 
> windows tool.

That is a known issue with said card having invalid configuration (i.e.,
something against Intersil documentation). Since I do not have any clear
document saying that this is allowed combination, I don't plan on
changing prism2_srec to allow this by default. There's a command line
option for ignoring some invalid combinations, but taken into account
how difficult it is to recover from failed firmware upgrade with
HFA3841, I cannot really recommend that this would be used. Yes, I know
it works in most cases, but still, I won't be recommending it.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list