problems with Linksys WET54G v.3 (fwd)

Jan Satko satko at quanto.nr.sanet.sk
Fri Feb 24 02:29:55 EST 2006


Can someone pls respond to my e-mail ? I can do something if i get some
advise or i can help with some debugging if needed. But i need to resolve
this problem, because i want use this configuration for doing WISP.
Thank you.

S pozdravom

--
   Bc. Jan 'EIS' Satko       Slovak University of Agriculture
 network & system manager            Tr. A. Hlinku 2
  Tel: +421 37 7412 616           949 76 Nitra Slovakia

---------- Forwarded message ----------
Date: Wed, 15 Feb 2006 09:25:52 +0100 (CET)
From: Jan Satko <satko at quanto.nr.sanet.sk>
To: hostap at shmoo.com
Subject: problems with Linksys WET54G v.3

Hi.

I have RH9 with compiled kernel 2.4.31 + wireless tools 28 + crypto
API. I'm using XI-626 with firmare 1.1.1(P) + 1.7.4 (S).
Latest hostap-utils, driver, and latest devel-hostapd because have still
same problems with previous versions.

So with Linksys WET54G v.3 i have lot of error in dmesg. As a result the
Linksys stop working after some hours. I need to manualy restart it to
work again. Firmware in Linksys is latest 1.08.

I'm using WPA-TTLS with latest freeradius.

Here are the errors:
TKIP: ICV error detected: STA=00:14:bf:dc:92:30
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-5
TKIP: ICV error detected: STA=00:14:bf:dc:92:30
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-5
TKIP: ICV error detected: STA=00:14:bf:dc:92:30
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-5
TKIP: ICV error detected: STA=00:14:bf:dc:92:30
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-5
TKIP: ICV error detected: STA=00:14:bf:dc:92:30
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-5
TKIP: ICV error detected: STA=00:14:bf:dc:92:30
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-5
TKIP: replay detected: STA=00:14:bf:dc:92:30 previous TSC 000000012687
received TSC 000000000001
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-4
TKIP: replay detected: STA=00:14:bf:dc:92:30 previous TSC 000000012687
received TSC 000000000002
wifi0: decryption failed (SA=00:14:bf:dc:92:30) res=-4
TKIP: replay detected: STA=00:14:bf:dc:92:30 previous TSC 000000012687
received TSC 000000000003

I try to use also firmware >= 1.8.0 (1.8.2,1.8.4) but with them i have
much more errors with also some resets of the card included. And XI-626
sometimes don't work (no frequency selected, no reposing to upgrading and
so on). So i resolve this by restarting system and everythink works again
for some time.


Can someone tell me how to solve this problem ? It seems to me that
problem (with 1.7.4 firmware) is changing TSC. Maybe hostap should
deauthenticate client to force him authenintacte again to solve problem
with wrong TSC ?

Thank you very much for you help.

S pozdravom

--
   Bc. Jan 'EIS' Satko       Slovak University of Agriculture
 network & system manager            Tr. A. Hlinku 2
  Tel: +421 37 7412 616           949 76 Nitra Slovakia
_______________________________________________
HostAP mailing list
HostAP at shmoo.com
http://lists.shmoo.com/mailman/listinfo/hostap



More information about the HostAP mailing list