hostapd with Atheros

Michael Plourde mplourde at digicom.ca
Wed Feb 22 08:35:24 EST 2006


Ok,

> > insmod: unresolved symbol crypto_alloc_tfm
> > insmod: unresolved symbol crypto_free_tfm

cause i have compile madwifi with a kernel in wich crypto_api module is not
enable
or
the linux kernel of my hostapd target (wisp on a PC-engine board) dont have
the crypto_api module

anyway it's not a hostapd problem...

----- Original Message ----- 
From: "Jouni Malinen" <jkmaline at cc.hut.fi>
To: <hostap at shmoo.com>
Sent: Tuesday, February 21, 2006 9:47 PM
Subject: Re: hostapd with Atheros


> On Tue, Feb 21, 2006 at 04:25:54PM -0500, Michael Plourde wrote:
>
> > still answer to myself, wlan* modules were not all loaded !
> > But when i try :
> > insmod wlan
> > insmod wlan_acl
> > insmod wlan_wep
> > insmod wlan_tkip
> > insmod wlan_ccmp
> >
> > got this error:
> >
> > insmod: unresolved symbol crypto_alloc_tfm
> > insmod: unresolved symbol crypto_free_tfm
> >
> > i know that's mean that a module is missing (not loaded) but wich one...
>
> madwifi-users mailing list would be more appropriate for this question.
> Those symbols are from Linux CryptoAPI, but I don't remember which
> module includes them. Is there any particular reason for using insmod
> instead of modprobe? modprobe would try to load all the needed modules
> without you even having to figure out which module was actually needed..
>
> -- 
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>




More information about the HostAP mailing list