Kernel Hang 2.6.11, 0.4.7, dual radios, Soekris boards

Punky punkytse at gmail.com
Mon Feb 20 20:19:06 EST 2006


Kelly,

I would suggest that you check the power supply unit first.  The PSU
may be underpower.  Moreover, if your board is running fine for one
card but not the two simultaneously, it is probably the power problem.

On 2/21/06, Kelly Hogan <kshogan at nomadisp.com> wrote:
> Jouni,
>
> We are seeing an odd situation when we have two MP2511 (fw 1.8.2) boards
> in a soekris sbc.  hostap driver loads fine after a complete power
> cycle, (power off the radios) and comes up and both MP2511's work well
> for about 36 hours.  Then, the system kernel hangs, and when the board
> watchdog reboots the board, the kernel loads fine, but when the hostap
> driver loads, it reports that the first (wifi0) board is detected, but
> when the second board is normally detected, the kernel hangs.  Again,
> the wathcdog will reboot, but the cycle continues until we completely
> powerdown the boards.  We have not seen this with single radio
> configurations.  However it seems to happen when one of the radios
> associates with encrypted APs.  That seems to be the thing that causes
> the "hang" of the radio, requiring complete powerdown.
>
> We have replicated the problem on 0.3.7 and with different FW versions
> on the boards (1.7.4)
>
> Any ideas as to what might be causing this?
>
> Thanks as always,
> Kelly
>
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>


--
--
Regards,
Punky
P U N K N ! X  . c o m
Technology + Lifestyle
(http://www.punknix.com)

Voyage Linux
(http://www.voyage.hk/software/voyage.html)



More information about the HostAP mailing list