wpa_supplicant: WPA: EAPOL-Key Replay Counter did not increase - dropping packet

Joey Richards joey at caltech.edu
Sat Feb 11 15:12:07 EST 2006


Hello,

I am suffering from the same problem as Vidar.  I'm running on an AMD 
Turion laptop with kernel 2.6.15-r1 built for x86_64.  My wireless card 
is a Broadcom, using the bcmwl5a 64-bit driver through ndiswrapper.  I 
connect to a Netgear WGR614 wireless router using WPA-PSK.

I have collected two logs -- one is an annotated log from wpa_supplicant 
with the -ddt option (search for <<<<< to find my comments).  The other 
is the iwevent log from the same period.  These are available at
http://www.its.caltech.edu/~joey/wpa_supplicant

What you'll see in the logs is my connecting to the access point 
(bork-wireless), accompanied by a couple events in the iwevent log. 
About 7 minutes later, wpa_supplicant successfully handshakes with no 
event in the iwevent log.  Next, about half an hour later, it attempts 
to handshake, fails due to the "Replay Counter" error, and repeats until 
I noticed the connection had died.  I closed wpa_supplicant and this 
caused the final iwevent activity -- reporting a connection to an access 
point with address 00:00:00:00:00:00.  There was no activity at all in 
the iwevent log after the initial connection until I shut down 
wpa_supplicant.

Any assistance would be most appreciated, now by two of us.  Please let 
me know if there are any other tests I can run that would help with 
diagnosis.

joey



More information about the HostAP mailing list