Madwifi-NG + hostapd + RSN

Leonardo Maccari maccari-thisaintpartofmyaddress- at lenst.det.unifi.it
Mon Feb 6 16:28:40 EST 2006


On Tue, Jan 31, 2006 at 12:51:40PM +0100, thomas schorpp wrote:
> Leonardo Maccari wrote:
> > On Mon, Jan 30, 2006 at 09:02:07AM +0100, Stijn Tintel wrote:
> > 
> for a working setup i use madwifi-old and debian kernels 2.6.14-15 (Wireless Extensions- /IEEE stack Version!) and hostapd 0.4.7 stable.

now I have 2.6.15:
lautrec:/home/leonardo/src/hostapd-0.4.7# iwconfig --version
iwconfig  Wireless-Tools version 27
          Compatible with Wireless Extension v11 to v17.

	  Kernel    Currently compiled with Wireless Extension v19.

	  ath0      Recommend Wireless Extension v13 or later,
	            Currently compiled with Wireless Extension v19.
		    

I've madwifi-old from svn, and hostapd 0.4.7, that is, nothing from debian
stable distribution.

The behaviour of madwifi driver is randomic.  I was able to have it working with hostapd and WPA-PSK,
having it ping for 10 minutes then it stops. After a random number of
stop&start of hostapd it freezes the kernel. 
Now I'm asking: is there a suggested kernel/madwifi combination that is
_stable_? 

> 
> ath0 is configured static inet auto and with channel,iwpriv mode 3,essid in interfaces file and up before starting hostapd. *
> 
> ive never tried hostapd on madwifi-ng because of outstanding critical bugs on madwifi.org tracker and it runs on my domain-server, 
> i cant risk to crash.
> 
> if you want you may surely need latest 2.6.15 and hostapd-cvs head.
> if kernel crashes pls attach serial (cable) console from another machine and/or ksymoops 
> to catch oops and report to madwifi.org bugtracker.

I'll try if I can, but the question remains: you say madwifi-new is
unstable, is there any stable version?

ciao,
leonardo.

-- 
   Key fingerprint = 3129 C583 F03B 2E73 0115  C040 3489 0185 B592 19FE
 Obviously -thisaintpartofmyaddress- is not part of my real email address 




More information about the HostAP mailing list