Leap

Jouni Malinen jkmaline at cc.hut.fi
Fri Feb 3 21:15:16 EST 2006


On Fri, Feb 03, 2006 at 02:54:32PM -0500, Matthew Cross wrote:

> I have an ipw2200BG, drivers are 1.0.10 which is
> reported to support leap, and ieee is 1.1.9 anything
> else that might help let me know and I'll check and
> post.

Which kernel version are you using?

> My wpa_supplicant.conf is:
> network={
>         ssid="ten-179-0"
>         scan_ssid=1

Please note that ipw2200 driver is unlikely to support scan_ssid=1
option. If you are using a hidden SSID, ap_scan=2 mode would be more
likely to work.

> When I try to run:
> wpa_supplicant -ieth1 -Dipw -c/etc/wpa_supplicant.conf

Can you please test with with -Dwext? ipw2200 is moving to use Linux
wireless extensions and I don't know whether things like authentication
algorithm configuration for Network EAP was added for the old -Dipw
ioctls.

> When I run
> wpa_supplicant -eth1 -Dndiswrapper
> -c/etc/wpa_supplicant.conf I get the same get the
> trying to associate and time out, but without the
> complaint of the ioctl thing.

This is invalid configuration if eth1 is using ipw2200 driver.
ndiswrapper uses its own private ioctls and ipw2200 does not use these.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list