hostapd/wpa_supplicant - new development release v0.5.5

Jouni Malinen jkmaline at cc.hut.fi
Mon Aug 28 02:22:10 EDT 2006


On Mon, Aug 28, 2006 at 03:35:31PM +1000, Kel Modderman wrote:

> wpa_gui-qt4 fails to compile since last development snapshot I had been 
> playing with (0.5-2006-08-21) as part of testing next debian package release. 

wpa_gui-qt4 is a bit in flux and you would probably be better off
building wpa_gui subdirectory instead since it can now be built with
both Qt3 and Qt4. I'm in the process of making the Qt4 version really
being Qt4 version by converting it to Qt4 style project and dropping
Qt3 compatibility classes. I didn't get this finished in time for 0.5.5
and the current wpa_gui-qt4 version has some issues.

> make[1]: Entering directory `/home/kel/debian/build/wpasupplicant-0.5.5/wpa_gui-qt4'
> g++ -c -pipe -O2 -Wall -W -D_REENTRANT  -DCONFIG_CTRL_IFACE -DCONFIG_CTRL_IFACE_UNIX -DQT_NO_DEBUG -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/Qt3Support -I/usr/include/qt4 -I. -I.. -I../../hostapd -I.moc -I.ui -o .obj/main.o main.cpp
> ./eventhistory.h:50: error: extra qualification ‘EventHistory::’ on member ‘EventHistory’

That was a copy-paste error on how the destructors are defined. I fixed
it in CVS now. Interestingly enough, the g++ version I'm using (3.4.6)
did not complain about this..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list