FYI: ICH5 SATA and HostAP

Petr Štochl jantar.cz at quick.cz
Fri Sep 30 12:27:49 EDT 2005


Hello.
I just want to inform you, that i have got strange problem, which looked like problems with 0.4.4 HostAP.
I have prepared long mail for this mailinglist, but i did not sent it, because problem was somewhere else.
I have Intel Bayfield i865G (ICH5) MB with 3x ZCOM XI-626 cards (2x in Master mode).
Debian testing with custom compilled kernel 2.4.31
I have found, that if i enable SATA support in BIOS (no SATA disk!), router locks about 3 times per day, everytime with this in kernel log:
Sep 26 12:12:09 shraamka kernel: NETDEV WATCHDOG: wifi2: transmit timed out
Sep 26 12:12:09 shraamka kernel: wifi2 Tx timed out! Resetting card
Sep 26 12:12:09 shraamka kernel: wifi2: CMD=0021 EVSTAT=0000 OFFSET0=0000 OFFSET1=0000 SWSUPPORT0=8a32
Sep 26 12:12:09 shraamka kernel: wifi2: scheduled card reset
Sep 26 12:12:09 shraamka kernel: hostap_pci: wifi2: resetting card
Sep 26 12:12:09 shraamka kernel: wifi2: Original COR value: 0x32
Sep 26 12:12:09 shraamka kernel: prism2_hw_init: initialized in 180 ms
Sep 26 12:12:15 shraamka kernel: NETDEV WATCHDOG: wifi2: transmit timed out
Sep 26 12:12:15 shraamka kernel: wifi2 Tx timed out! Resetting card
Sep 26 12:12:15 shraamka kernel: wifi2: CMD=0021 EVSTAT=0000 OFFSET0=0000 OFFSET1=0000 SWSUPPORT0=8a32
Sep 26 12:12:15 shraamka kernel: wifi2: scheduled card reset
Sep 26 12:12:15 shraamka kernel: hostap_pci: wifi2: resetting card
Sep 26 12:12:15 shraamka kernel: wifi2: Original COR value: 0x32
Sep 26 12:12:15 shraamka kernel: prism2_hw_init: initialized in 190 ms

It took me few days to find that it is caused by SATA enabled in BIOS. (it happens only to cards in Master mode)
I did not try new BIOS and i also left firmware in cards at 1.1.1/1.7.4.
So, it is for your information, that it could happen.
I have some small questions:
Have got someone same SATA problems with Intel chipset?
Which card FW is recommended for HostAP 0.4.4?
Kernel 2.4.31 have WE v16 - HostAP 0.4.4 recommends v18 - could it be problem, or is possible to patch this kernel to v18? (I could not use 2.6 kernel, because lmsensors have different output format)
Thanks.
Petr, czfree.net
PS: i have all 6 PCI slots used (3x 626, 1x Atheros, 1port Intel LAN, 2port Intel LAN) and it looks stable, but Atheros and two ETH cards are not yet used.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20050930/06e2d622/attachment.htm 


More information about the HostAP mailing list