Can't ping AP, but DHCP and inter-client pings work

Adam Hooper adamh at densi.com
Mon Sep 19 23:44:43 EDT 2005


I recently installed Ubuntu on a little computer of mine, and I'm having
a problem with wireless. I used to run a compiled-from-source HostAP on
Linux 2.6.6 (Debian), and it worked (i.e., the hardware is fine). I'm
now running Ubuntu's 2.6.12-8 kernel, which comes HostAP modules.

So, what *works*?

- I can run "ifup wlan0", which gives wlan0 a static IP, 192.168.2.100,
and calls iwconfig to set its name and essid. It is set to mode
"Master".
- I can start a DHCP server on wlan0.
- From a wireless client, I can receive an address via DHCP.
- I can ping from one wireless client to another wireless client.

What *doesn't* work?

- I can't ping from client to access point or vice-versa.
- I can't connect to the Internet from clients (through the access
point's MASQUERADE-ing).

When I ping from client to AP and run tcpdump on the AP, I see some "arp
who-has" packets and nothing else. When I ping from the AP to the
client, tcpdump shows nothing at all.

I'd suspect routing tables, but they seem fine. Output from "ip route":

192.168.2.0/24 dev wifi0  proto kernel  scope link  src 192.168.2.100
192.168.2.0/24 dev wlan0  proto kernel  scope link  src 192.168.2.100
192.168.1.0/24 dev eth1  proto kernel  scope link  src 192.168.1.100
xx.xx.xx.0/24 dev eth0  proto kernel  scope link  src xx.xx.xx.xx
default via xx.xx.xx.1 dev eth0

I only have one firewall rule:

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

(all policies are ACCEPT).

It seems like the answer must be obvious, but I just can't figure it
out. What could be wrong?

-- 
Adam Hooper <adamh at densi.com>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20050919/750213d7/attachment.pgp 


More information about the HostAP mailing list