[wpa-supplicant] Wireless-extension v19

Jean Tourrilhes jt at hpl.hp.com
Mon Sep 19 13:07:52 EDT 2005


On Sun, Sep 18, 2005 at 08:43:34PM -0700, Jouni Malinen wrote:
> On Fri, Sep 09, 2005 at 09:10:33PM +0200, Benoit Boissinot wrote:
> 
> > Thanks for the comments, here is a revised version (tested with WPA2/RSN
> > and 2.6.13-mm2).
> 
> This does not work with WE-18 and I would assume the same is true for
> the previous patch since the problem is in the changes in wireless.h. It
> looks like IW_EV_POINT_LEN changed and if wpa_supplicant is built with
> wireless.h from v19, older versions do not work. This is quite
> unfortunate.

	Ok, that's a bug and that's fixable. I mananaged to do it in
WT, so there must be a way. Let me think 2 sec about it.

> I did not realize that WE-19 is changing kernel-user space interface in
> a backwards incompatible way. If I had, I would have objected to it.

	Let's not overreact. API changes happen all the time.

> Jean, have I misunderstood something or is this really changing the
> event messages in a way that all user space programs need to be
> recompiled or actually even worse, if they use IW_EV_POINT_LEN, modified
> to support both old and new format and then recompiled? If that is the
> case, was this change really needed?

	Yes, I believe so. Having a pointer in there doesn't make the
event format 32/64 bit clean, if you use a 32 bit userspace with a 64
bit kernel you will end with potential trouble.

> Jouni Malinen

	Have fun...

	Jean




More information about the HostAP mailing list