compile EAP-FAST support doesn't work

Jouni Malinen jkmaline at cc.hut.fi
Wed Sep 14 12:42:20 EDT 2005


On Wed, Sep 14, 2005 at 12:17:09PM -0400, biozaal at mac.com wrote:

> I'm attempting to build on an IBM Thinkpad R51 using Fedora Core 4 and I do believe it's using the latest version of OpenSSL 0.9.7-f.  I'm attempting to compile in support for an Intel 2100 wireless card and EAP-FAST.  I'm getting an error when attempting to make:

> tls_openssl.c:1599: warning: implicit declaration of function ?SSL_set_session_secret_cb?

There's a reason for EAP-FAST not being listed in defconfig.. In other
words, you need to patch OpenSSL in order to be able to use EAP-FAST.
The included patch (openssl-tls-extensions.patch) can be used with
OpenSSL 0.9.8 to add the needed functionality to OpenSSL.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list