wpa_supplicant problem after kernel upgrade

engage engage at n0sq.us
Sun Oct 23 13:38:13 EDT 2005


On Sunday 23 October 2005 03:15 am, Henrik Brix Andersen wrote:
>On Sat, Oct 22, 2005 at 08:07:55PM -0600, engage wrote:
>> I just installed kernel 2.6.13.4. The drivers for ipw2200 (1.0.8) and
>> ieee80211 (1.1.6) are loaded and iwconfig  shows wlan0. Firmware 2.4 was
>> installed in the appropriate firmware directory. I was using
>> wpa_supplicant-0.3.9 prior to the kernel upgrade. I tried recompiling (no
>> errors) and installing but I still cannot connect to my AP. So I tried
>> upgrading to wpa_supplicant-0.4.5. It compiled & installed OK but running
>> wpa_supplicant still produces:
>>
>> ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
>
>You need to use -D wext instead of -D ipw when running a WE-18 enabled
>kernel (2.6.13+).
>

I changed the command to -D wext and received "unsupported driver wext". I 
tried -Dwext (without the space) and got the same thing. Also, I didn't see 
any reference to the -e and -x commands in the readme for the command line 
options for wpa_supplicant.

I don't know if the following is an issue (part of output from running 
iwconfig):

Warning: Driver for device wlan0 has been compiled with version 18 of Wireless 
Extension, while this program supports up to version 17. Some things may be 
broken...

I tried to uninstall the wireless-tools package with urpme so that I could 
install the latest tarball but I got a message that would break my system so 
I left things as is. 

Originally, this was Mandriva 2005LE.





More information about the HostAP mailing list