hostap-0.4.5 compilation problems on debian 3.1 with WE18 with madwifidriver

Jouni Malinen jkmaline at cc.hut.fi
Thu Oct 20 23:55:06 EDT 2005


On Thu, Oct 20, 2005 at 09:56:35AM -0300, Beat Meier wrote:

> hostapd-0.4.5 doesn't anymore compile on debian 3.1 with kernel 2.6.12 
> (hostapd-0.4.4 did)

Which version of glibc is used on your Debian 3.1? I can compile
hostapd/driver_madwifi.c without problems on Gentoo (glibc 2.3.5),
Fedora Core 4 (glibc 2.3.5), and Debian 3.1 (libc6 2.3.2).

> If I include <linux/wireless.h> instead of  wireless_copy.h it complais 

linux/wireless.h should not be included into user space programs.

> I have WE18.
> Does hostap-0.4.5 compile only with WE19?

hostapd is meant to be built with wireless_copy.h.

> And at last there are 2 if.h one in t/usr/include/net and one in
> /usr/include/linux in the sytem path but in the kernel sources
> there is only the /usr/include/linux one so if you add the kernel sources
> (which was stripped away in the defconfig now - why?)
> the if.h from system kernel is used. Is this the right one???

Kernel header files shoul not be included when building hostapd.

> How can we change that and why was wireless_copy.h added?

Change what? wireless_copy.h is used because linux/*.h headers are not
safe to be included into user space programs.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list