Bridging with madwifi

Timo Pannes timo.pannes at gmx.net
Sat Oct 15 13:21:18 EDT 2005


Hi,

I have exactly the same problem as you and Thomas. I also posted it two times 
but without any answer or solution. I really hope someone will solve it 
soon...

Regards,
Timo


On Saturday 15 October 2005 14:01, Nick Stefaniak wrote:
> On Sat, 15 Oct 2005 11:44, Thomas Heiz wrote:
> > Hi all
> >
> > I want to set up hostapd with bridge between a madwifi card and wired
> > ethernet. I've inserted a line "bridge=br0" in my hostapd.conf.
> >
> > For the bridge, I used the example "Bridging between wireless and
> > wired networks" in the readme file from the hostapd.
> >
> > The bridge works fine without hostapd (clients can connect without
> > encryption).
> >
> > When I start hostapd, everything seems to be OK, but when a station
> > wants to connect, the following error occures.
> >
> > frame too short for this IEEE 802.1X packet
> >
> > Has anyone successfully set up a bridge with a madwifi card?
> >
> > thanks
> > Thomas Heiz
> > _______________________________________________
> > HostAP mailing list
> > HostAP at shmoo.com
> > http://lists.shmoo.com/mailman/listinfo/hostap
>
> Hi,
>
> I want to use hostapd (madwifi driver) with bridge and I have the same
> problem - clients are unable to authorize (WPA-PSK). Adding bridge=br0 line
> to hostapd.conf haven't bring any effects. Following errors occcures: ...
> WPA: sending 1/4 msg of 4-Way Handshake
> WPA: EAPOL-Key timeout
> ..
> frame too short for this IEEE 802.1X packet
> ...
>
> When ath0 is not attached to bridge, everything works fine. I already
> posted this problem (no response), but now I see that I am not alone ;-)
> Thanks in advance for any help.
>
> best regards,
> Nick Stefaniak
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap



More information about the HostAP mailing list