wpa_supplicant not working in Windows

Bryan Kadzban bryan at kadzban.is-a-geek.net
Thu Oct 13 07:07:12 EDT 2005


Alicia Caminero Caminero wrote:
> a wireless net which uses IEEE 802.1X with EAP-MD5.

Yikes.  You realize MD5 is pretty weak, right?  And vulnerable to
offline dictionary attacks?  (Although maybe you didn't decide what to
use for authentication.)

> - wpa_supplicant for Windows 0.3.9

Have you tried 0.4.5?  Might help.

> My concrete problem is that it seems that, on one hand,
> wpa_supplicant stays in the state "Authenticating" endlessly, but on
> the other hand, the radius server says that I've been authenticated 
> succesfully.

If you aren't using WEP (i.e. if you have a 4-way handshake going on),
then this might be similar to the issues I was seeing with WPA2-AES with
versions prior to 0.4.5.  The packet-check interval was too short, and
the AP timed out the 4-way handshake too early, so while RADIUS did
succeed, the machine never got to pass any traffic.

Even if you are using WEP encryption, this might be related.  Or there
might be another set of fixes in 0.4.5 that might help.

> 2. "ndis_get_oid: oid=0xd010101 len (6) failed": I haven't got a clue
> of what does this mean.

I don't know either, but we get them all the time too, even when it does
work.  (I think that OID is "get the current BSSID", but I don't know
that for sure.)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 256 bytes
Desc: OpenPGP digital signature
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20051013/09abf3af/attachment.pgp 


More information about the HostAP mailing list