MIC failure after 4 way handshake (after PTK is installed and before GTK is received)

Bar, Eitan eitanb at ti.com
Thu Oct 6 03:14:07 EDT 2005


Hi,
 
I’ve tried both wpa_upplicant 0.3.9 and 0.4.4, but the problem remains the same – I receive MIC failures from the driver right after the PTK is set and the AP transmits the GTK (encrypted)
 
A zipped sniffer (Airopeek) capture file is included, and also below is a dump taken from wpa_supplicant (0.4.4 in this case).
NOTE: please IGNORE the debug messages about the invalid scan results, this is a different story. In anyways - I’m providing the AP RSN/WPA IE through EVENT_ASSOCINFO event).
 
I did verify that the key is relayed to the driver as it should (16 bytes key, 8 bytes RX MIC, 8 bytes TX MIC).

(Also, a small note: this driver has already been verified to work with another supplicant, so I assume the MIC check in driver/firmware is valid).
 
I would really appreciate any help or suggestions as to what can be wrong.
If anybody else has encountered this situation before I would like to hear what solved it...

Could this be a big/little endian issue? I really have no clue…
 
Thanks!
 Eitan

p.s: wpa_supplicant log is also attached as zip file (sorry, msg was too big to send)...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mic_failure_1.zip
Type: application/x-zip-compressed
Size: 2258 bytes
Desc: mic_failure_1.zip
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20051006/ddd81c65/attachment.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mic_failure.zip
Type: application/x-zip-compressed
Size: 3467 bytes
Desc: mic_failure.zip
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20051006/ddd81c65/attachment-0001.bin 


More information about the HostAP mailing list