Problem with SMC2532W-B V2 (0xd601 0x0010)

James Henderson his_jimboness at yahoo.ca
Sun Oct 2 16:40:35 EDT 2005


Hello,

I'm having a tough time getting this card working in hostap.  From my 
googling, I've determined that this is the version 2, Prism3 card 
(version 1 was Prism2.5).  It's a high-power 200mW pc card.

I'm running Gentoo 2005.1, kernel 2.6.12-gentoo-r10, pcmcia-cs-3.2.8, 
and I've tried both hostap-0.3.9 and hostap-0.4.4

I've had to add the following, per other people's hints, to 
/etc/pcmcia/hostap.conf:

card "SMC2532W-B EliteConnect Wireless Adapter"
    version "SMC", "SMC2532W-B EliteConnect Wireless Adapter", "", ""
    manfid 0xd601, 0x0010
    bind "hostap_cs"

In the syslog, I see the following when issuing "cardctl insert" (or 
when just plugging the card in):

Oct  2 16:09:33 hostname cardmgr[11742]: socket 0: SMC2532W-B 
EliteConnect Wireless Adapter
Oct  2 16:09:34 hostname hostap_crypt: registered algorithm 'NULL'
Oct  2 16:09:34 hostname hostap_cs: 0.3.9 - 2005-06-10 (Jouni Malinen 
<jkmaline at cc.hut.fi>)
Oct  2 16:09:34 hostname hostap_cs: setting Vcc=33 (constant)
Oct  2 16:09:34 hostname hostap_cs: CS_EVENT_CARD_INSERTION
Oct  2 16:09:34 hostname hostap_cs: setting Vcc=50 (from config)
Oct  2 16:09:34 hostname Checking CFTABLE_ENTRY 0x01 (default 0x01)
Oct  2 16:09:34 hostname IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
Oct  2 16:09:34 hostname io->flags = 0x0047, io.base=0x0000, len=128
Oct  2 16:09:34 hostname hostap_cs: Registered netdevice wifi0
Oct  2 16:09:34 hostname hostap_cs: index 0x01: Vcc 5.0, irq 3, io 
0x0200-0x027f
Oct  2 16:09:34 hostname net.agent[11781]: add event not handled
Oct  2 16:09:34 hostname prism2_hw_init: initialized in 193 ms
Oct  2 16:09:34 hostname prism2_enable_aux_port(1) timed out
Oct  2 16:09:34 hostname prism2_enable_aux_port: was not enabled!?
Oct  2 16:09:34 hostname wifi0: valid PDA not found
Oct  2 16:09:34 hostname wifi0: hfa384x_cmd_issue: cmd reg was busy for 
9 usec
Oct  2 16:09:36 hostname wifi0: hfa384x_cmd: entry still in list? 
(entry=ca9512c0, type=0, res=0)
Oct  2 16:09:36 hostname wifi0: hfa384x_cmd: command was not completed 
(res=0, entry=ca9512c0, type=0, cmd=0x0021, param0=0xfd0b, EVSTAT=8000 
INTEN=0010)
Oct  2 16:09:36 hostname wifi0: hfa384x_get_rid: CMDCODE_ACCESS failed 
(res=-110, rid=fd0b, len=8)
Oct  2 16:09:36 hostname Could not get RID for component NIC
Oct  2 16:09:36 hostname hostap_cs: Initialization failed
Oct  2 16:09:36 hostname prism2_config() failed
Oct  2 16:09:36 hostname cardmgr[11742]: executing: './network start 
wifi0 2>&1'
Oct  2 16:09:36 hostname cardmgr[11742]: + ./network: line 28: 
/etc/init.d/net.wifi0: No such file or directory
Oct  2 16:09:36 hostname cardmgr[11742]: start cmd exited with status 127

As you can see, it can't find a valid PDA even though other people have 
claimed success with this card and hostap.

"cardctl info" outputs:
PRODID_1="SMC"
PRODID_2="SMC2532W-B EliteConnect Wireless Adapter"
PRODID_3=""
PRODID_4=""
MANFID=d601,0010
FUNCID=6

By the way, I have two of these cards and they both do the same thing. 
I'm doubting problems with the hardware itself.  And I haven't tried 
them in Windoze yet (nor do I have the means to do so...).

Any ideas folks?

Thank you,
James
__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



More information about the HostAP mailing list