Problem with changing the transmission power (txpower)

Pablo Osuna posuna at ehas.org
Tue Nov 15 16:17:29 EST 2005


Please see:

http://list.voyage.hk/pipermail/voyage-linux/2005-November/000448.html

You should upgrade your driver to a newer version (0.3.9 or 0.4.5)

Regards:

Pablo

El mar, 15-11-2005 a las 16:12 -0500, Yaoyao Gu escribió:
> Hi,
>  
> I am really new to this community. So please let me know if this
> topic has been well discussed before.  I am using Linksys wcf12
> wireless cf card. The version of the hostap driver is 0.2.5. I
> met some problem when I tried to reduce the transmission power of
> the cf wireless card.
>  
> When I execute the following commands, it gives me the error message
> such as "no private ioctl supported".
> 
> $ iwpriv wlan0 prism2-param 5 1  //change the alc to auto control 
>                                                     // I have also
> tried 0 value here 
>                                                     // but it
> generates the same error later
> $ iwpriv wlan0 prism2-param 6 103  // set the tx power to 103  
> 
> I have also tried $iwconfig wlan0 txpower 103, and it gives me the
> following message. I guess it's the same problem.
> Error for wireless request "Set Tx Power" (8B26) :
> SET failed on device wlan0 ; Operation not supported.
> Several possible reason I can guess: 1) The cf card doesn't support
> transmission power control. 2) The version of hostap I have doesn't
> support txpower.
>  
> I checked $ iwpriv and it gives a list of parameters that iwpriv can
> control.  I didn't find txpower in it. But alc is there. I think
> that's why I can change alc setting. So does that mean that the hostap
> doesn't support txpower in the current version. If that's the case,
> how can I solve this problem? Do I need to modify the driver by
> myself? 
>  
> Thanks in advance. Any thoughts or suggestions are highly appreciated.
>  
> Cheers,
>  
> Yaoyao
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap




More information about the HostAP mailing list