[Madwifi-devel] Re: How to compile hostapd-0.4.6 and wpa_supplicant-0.4.6 for madwifi-ng (1314)

Jouni Malinen jkmaline at cc.hut.fi
Sat Nov 12 10:08:04 EST 2005


On Sat, Nov 12, 2005 at 06:59:30AM -0800, Jouni Malinen wrote:
> On Sat, Nov 12, 2005 at 07:23:45PM +1000, Kel Modderman wrote:
> > Is it too much of a burden on you to support multiple madwifi versions 
> > at once?
> 
> It would be somewhat complex. One could either create two separate
> driver interfaces in wpa_supplicant (e.g., driver_madwifi.c and
> driver_madwifi_ng.c)

Actually, for wpa_supplicant, the easiest solution would be to start
using driver_wext.c by someone adding WE-18 support to madwifi-ng.. This
would get rid of need to maintain separate driver interface code in the
future and driver_madwifi.c could be built against madwifi-old headers.
Sure, this would not solve all issues (e.g., using madwifi-ng with WE-17
or older), but it would certainly be nicer as far as the goal of getting
Linux driver using common interface is concerned.
 
-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list