wpa_supplicant-0.4.6 with madwifi-ng now compiles but does still not associate to hostapd

Beat Meier bmeier at infovia.com.ar
Tue Nov 1 08:25:57 EST 2005


Hi

At least I were able to compile hostapd-0.4.6. and wpa_supplicant-0.4.6 
with kernel 2.6.14 and WE19 and
madwifi-ng (), but wpa_supplicant it still doesn't work.
With kernel 2.6.12 and madnwifi-ng it was the same.
wpa_supplicant cannot connect to hostapd. It "hangs" by scanning. Last 
messages below.

Nov 01 09:40:05.902507: Added interface ath0
Nov 01 09:40:05.904041: Wireless event: cmd=0x8b06 len=8
Nov 01 09:40:05.905437: Ignore event for foreign ifindex 3
Nov 01 09:40:05.906722: RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
Nov 01 09:40:05.908131: RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
Nov 01 09:40:06.003678: State: DISCONNECTED -> SCANNING
Nov 01 09:40:06.004720: Starting AP scan (broadcast SSID)
Nov 01 09:40:06.005970: Wireless event: cmd=0x8b1a len=8

Have also tried to use with scan_ssid=1 but it's the same. It hangs ...
Any idea what's wrong?

Has anybody running wpa_supplicant with madwifi-ng?

wpa_supplicant-0.4.3 with old madwifi-bsd-driver works well to
hostapd-0.4.6 with madwifi-ns so the problem is really in wpa_supplicant.
I think there is something wrong with the ioctls in driver_madwifi.c.

Jouni  have you used already madwifi-ng???

Beat




More information about the HostAP mailing list