unable to get madwifi driver built into wpa_supplicant

Thomas Bishop bishop.thomas at gmail.com
Wed May 18 08:23:48 EDT 2005


Thanks for the response.  I tried rebuilding; no luck.

My madwifi source is at /usr/src/madwifi.  My wpa_supplicant source is at
/usr/src/wpa_supplicant.  Latest versions of both.

Here is the contents of my .config:

CONFIG_DRIVER_MADWIFI=y
CONFIG_WIRELESS_EXTENSION=y

The section I changed in the Makefile:

ifdef CONFIG_DRIVER_MADWIFI
CFLAGS += -I/usr/src/madwifi
OBJS += driver_madwifi.o
CONFIG_WIRELESS_EXTENSION=y
endif

Here is the output of make:

cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o config.o config.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o eloop.o eloop.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o common.o common.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o md5.o md5.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o rc4.o rc4.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o sha1.o sha1.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o aes_wrap.o
aes_wrap.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o driver_madwifi.o
driver_madwifi.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o tls_none.o
tls_none.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o driver_wext.o
driver_wext.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o wpa_supplicant.o
wpa_supplicant.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o wpa.o wpa.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o l2_packet.o
l2_packet.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o drivers.o drivers.c
cc -o wpa_supplicant config.o eloop.o common.o md5.o rc4.o sha1.o aes_wrap.o
driver_madwifi.o tls_none.o driver_wext.o wpa_supplicant.o wpa.o l2_packet.o
drivers.o 
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o wpa_passphrase.o
wpa_passphrase.c
cc -o wpa_passphrase wpa_passphrase.o sha1.o md5.o 
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o wpa_cli.o wpa_cli.c
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils -I../hostapd
-I/usr/src/madwifi  -DCONFIG_WIRELESS_EXTENSION   -c -o wpa_ctrl.o
wpa_ctrl.c
cc -o wpa_cli wpa_cli.o wpa_ctrl.o 

I noticed that madwifi is mentioned a few times, but I am not quite sure
what it is doing (maybe including source files from my madwifi source dir?).
Any help would be appreciated.  Thanks.

-Thomas

-----Original Message-----
From: hostap-bounces+bishop.thomas=gmail.com at shmoo.com
[mailto:hostap-bounces+bishop.thomas=gmail.com at shmoo.com] On Behalf Of Jouni
Malinen
Sent: Tuesday, May 17, 2005 10:49 PM
To: hostap at shmoo.com
Subject: Re: unable to get madwifi driver built into wpa_supplicant

On Tue, May 17, 2005 at 10:42:53PM -0400, Thomas Bishop wrote:

> No driver interfaces build into wpa_supplicant"
> 
> I have verified both the .config and Makefile entries as described in the
> link above.  Am I missing something?  I have a feeling it is something
small
> that I am overlooking.

If you changed .config file after building wpa_supplicant, please try
doing a full build again (make clean; make). If that does not fix this
problem, please send the .config file you are using.

-- 
Jouni Malinen                                            PGP id EFC895FA
_______________________________________________
HostAP mailing list
HostAP at shmoo.com
http://lists.shmoo.com/mailman/listinfo/hostap




More information about the HostAP mailing list