hostap in SuSE9.2 - bridging and kernel production

Karl Rothenhöfer Karl.Rothenhoefer at
Tue May 17 05:04:50 EDT 2005

Hello everybody,

recently I started migration of my WLAN-Network from SuSE 9.1 to 9.2 and I
experience some issues.

Issue 1: Bridging
Though in 9.1 I gained some experience with bridging, I fail to make it work
in 9.2.

The following are my commands:

sempron:~ # brctl addbr mybr
sempron:~ # brctl addif mybr eth0
sempron:~ # brctl addif mybr wlan0
sempron:~ # ifconfig eth0
sempron:~ # ifconfig wlan0
sempron:~ # ifconfig mybr netmask up

The following is, what I recorded with tail -f /var/log/messages

May 17 10:25:50 sempron ifup: No configuration found for mybr
May 17 10:25:57 sempron kernel: eth0: Promiscuous mode enabled.
May 17 10:25:57 sempron kernel: device eth0 entered promiscuous mode
May 17 10:26:04 sempron kernel: device wlan0 entered promiscuous mode
May 17 10:26:24 sempron kernel: eth0: Promiscuous mode enabled.
May 17 10:27:50 sempron kernel: mybr: no IPv6 routers present

So there is no indication of the learning phase of the bridge and no
indication of its transition to the forwarding state. After this the bridge
doesn't work.
In rare cases I saw the thing even work but without any reproducability and
with no evident explanation.

On another similar configuration, I see that the ethernet port enters
forwarding state but the wlan port still doesn't.

Latter experience made me question the status of the hostap-driver in SuSE
9.2 and they indicate a version 0.2.4-5 which I am currently using together
with Kernel version 2.6.8-24.14.

I therefore decided to go for a new kernel production with hostap version

Issue 2: Kernel Production with hostap 0.3.7
In following the README files for the kernel patches I wanted to apply the
patches for my kernel but the most recent patch availbale was
hostap-linux-2.6.2.patch. My understanding of its contents was not very
good, but nevertheless I tried to make some adaptations to my more recent
environment. Based on these adaptations I got the impression that I
successfully applied the patch. However the command make xconfig reveals
that no changes for the hostap options have been achieved.

Is there anybody who made simalar experience and could overcome it?
How can I solve the bridging issue?
How can I get/produce a better kernel patch?

Many thanks to everybody, who can help me to make progress after a couple of
unsuccessful days.

Many regards
Karl Rothenhöfer

More information about the HostAP mailing list