Problems with wpa_supplicant/ipw2200/D-link

Chris Ross cross+wpa at distal.com
Sun Mar 20 23:11:09 EST 2005


Pedro Ramalhais wrote:

> Make sure you have the latest driver. Use the ./unload and ./load 
> scripts to load the driver to make sure the loaded driver is the latest.


  Ahh.  Okay.  I looked into this s'more.  It wasn't that I was loading 
the wrong
driver, it was that it wasn't compiling right.  I'm not 100% sure why, 
but perhaps
because this distribution was built with an old version of the ipw2200 
module,
it got defaults from somewhere.  If I comment out the ifdef in the makefile,
and cause it to set EXTERNAL_BUILD to "y", it gets all the defs right and
compiles the module with WPA support.

  I did that, and now get different output.  Unfortunately, I appear not 
to have
saved that output anywhere.  I'll have to regenerate it.  :-(  The last 
time I
tried to run wpa_supplicant, it wedged my interface so much that I couldn't
get it back, and had to reboot.  So I'll compose a new message once I 
have the
output saved.

  Thanks...

                                        - Chris




More information about the HostAP mailing list