configuring wireless connection - beginner

Jay Strauss me at heyjay.com
Mon Jun 27 23:42:50 EDT 2005


Hi,

Please read all the way down, I've done a bunch of stuff and gave 
listings of each.

I fixed my space problem, upgraded my kernel now I'm running:

hydrogen:~# uname -a
Linux hydrogen 2.6.8-2-686 #1 Thu May 19 17:53:30 JST 2005 i686 GNU/Linux

And I did:
aptitude install hostap-modules-2.6.8-2-686

And I can
modprobe hostap

At this point I thought I was getting somewhere.  so I changed my
/etc/pcmcia/config file and added:

device "hostap_pci"
   class "network" module "hostap_pci"

card "Intersil PRISM2 11 Mbps Wireless Adapter"
   manfid 0x0156, 0x0002
   bind "hostap_pci"

# And commented out
#card "Intersil PRISM2 11 Mbps Wireless Adapter"
#  manfid 0x0156, 0x0002
#  bind "orinoco_cs"

*NOTE* I also tried the above with "hostap_cs"

But when I

hydrogen:~# wpa_supplicant -d -Dhostap -ieth0 -c/etc/wpa_supplicant.conf
Initializing interface 'eth0' conf '/etc/wpa_supplicant.conf' driver
'hostap'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
Priority group 0
    id=0 ssid='linksys'
Initializing interface (2) 'eth0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
ioctl[SIOCSIWPMKSA]: Operation not supported
ioctl[SIOCSIWMODE]: Operation not supported
Could not configure driver to use managed mode
Own MAC address: 00:d0:59:83:5f:d2
wpa_driver_hostap_set_wpa: enabled=1
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
Failed to enable WPA in the driver.
wpa_driver_hostap_set_wpa: enabled=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
Failed to disable WPA in the driver.
wpa_driver_hostap_set_drop_unencrypted: enabled=0
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
wpa_driver_hostap_set_countermeasures: enabled=0
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported

And when I:

hydrogen:~# ifup eth0
Internet Software Consortium DHCP Client 2.0pl5
Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.
All rights reserved.

Please contribute if you find this software useful.
For info, please visit http://www.isc.org/dhcp-contrib.html

sit0: unknown hardware address type 776
wifi0: unknown hardware address type 801
sit0: unknown hardware address type 776
wifi0: unknown hardware address type 801
Listening on LPF/eth0/00:d0:59:83:5f:d2
Sending on   LPF/eth0/00:d0:59:83:5f:d2
Sending on   Socket/fallback/fallback-net
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
No DHCPOFFERS received.
No working leases in persistent database.

Exiting.

Failed to bring up eth0.

And lastly I get when I dmesg:

hostap_crypt: registered algorithm 'NULL'
hostap_pci: 0.3.7 - 2005-02-12 (Jouni Malinen <jkmaline at cc.hut.fi>)
ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 11 (level, low) -> IRQ 11
hostap_pci: Registered netdevice wifi0
wifi0: Original COR value: 0x21
prism2_hw_init: initialized in 197 ms
wifi0: NIC: id=0x8013 v1.0.0
wifi0: PRI: id=0x15 v1.0.5
wifi0: STA: id=0x1f v1.3.3
wifi0: defaulting to host-based encryption as a workaround for firmware
bug in Host AP mode WEP
wifi0: defaulting to bogus WDS frame as a workaround for firmware bug in
Host AP mode WDS
wifi0: Intersil Prism2.5 PCI: mem=0xf0000000, irq=11
wifi0: registered netdevice wlan0
...
NET: Registered protocol family 10
Disabled Privacy Extensions on device c0300140(lo)
IPv6 over IPv4 tunneling driver
wifi0: invalid skb->cb magic (0x00000000, expected 0xf08a36a2)
wifi0: invalid skb->cb magic (0x00000000, expected 0xf08a36a2)
eth0: no IPv6 routers present

can you put some more crumbs on the trail for me to follow?

Thanks
Jay

Jouni Malinen wrote:
> On Sun, Jun 26, 2005 at 11:02:58PM -0500, Jay Strauss wrote:
> 
> 
>>I can't find where orinoco is loaded during boot.  There is no listing 
>>of it in my /etc/modules.  How do I prevent a conflict?
> 
> 
> PC Card drivers are usually loaded by cardmgr, so you would need to
> change its configuration (usually in /etc/pcmcia).
> 







More information about the HostAP mailing list