AR5112 card working with madwifi-bsd, hostapd-0.4.1,wpa_supplicant-0.4.1(andopenssl-0.9.7g)

Beat Meier bmeier at infovia.com.ar
Sat Jun 4 16:30:38 EDT 2005


and hansen schrieb:

>Beat Meier wrote:
>
>  
>
>>Hello again
>>
>>Now it works ...
>>
>>"Configuration":
>>  hostapd-0.4.1, wpa_supplicant-0.4.1
>>  madwifi-bsd-20050530
>>  openssl-0.9.7g
>>
>>Notes:
>>hostapd-0.4.1
>>I had to change the .config file of hostapd  so it
>>can find the crypto 
>>lib of ssl.
>>This seems strange but it is a real problem if you
>>have 2 ssl 
>>installations!!
>>In fact this could be a problem for many peobles
>>because in wpa_supplicant you can configure which
>>ssl should be used
>>and in hostapd there is no comment ...
>>In hostapd the crypto lib of the system (/usr/lib)
>>was linked instead of 
>>the /usr/local/lib one.
>>
>>It should be the same note in defconfig in hostapd
>>like in wpa_supplicant.
>>
>># Uncomment following two lines and fix the paths if
>>you have installed 
>>openssl
>># in non-default location
>>#CFLAGS += -I/usr/local/openssl/include
>>#LIBS += -L/usr/local/openssl/lib
>>
>>So I was able to use my NL-5354 MP PLUS ARIES2(F) 4G
>>chipset AR5112
>>at both end client and ap to connect with WPA-PSK.
>>    
>>
>
>Hello Beat Meier and others
>
>more details please ;)
>1 are you using madwifi-bsd in both ends ?
>
>  
>
Yes I'm using madwifi-bsd on both ends with kernel-2.4.30
Hostapd if compiled on suse9.1 with kernel-2.4.30
wpa_supplicant is compiled on debian-3.01r1 woody with kernel-2.4.30
On both systems I have installed the sources hostapd-4.0.1 and 
wpa_supplicant-4.0.1
and configured the wpa_suuplicant in .config of hostapd i.e. compiling 
include
-I../wpa_supplicant-0.4.1
Make shure your path is correct (ls path output of make from hostapd 
compile dir!)
The same I have done for wpa_supplicant .conf file with source dir of 
hostapd.
BTW: this is in CFLAGS entry in defconfig line 50 (wpa_supplicant-0.4.1)
CFLAGS entry in defconfig line 20 /hostapd-0.4.1)
I don't now if this must be done, but ...
Importend is that you add the 2 lines mentioned about ssl in the .config 
file of hostapd i.e.

CFLAGS += -I/usr/local/openssl/include
LIBS += -L/usr/local/openssl/lib

which MUST point to your openssl lib IF not using the default from the 
system!

>2 have you removed the the openssl
>  that were following you distribution,
>  or have you just pointed out the openssl-0.9.7g
>  source in the .config files ?
>
>  
>
I've deleted it because never worked and so I've noticed that the linker 
complained about missing
library. After patching .config like above it worked. I've installed 
again the openssl lib

>3 are you using openssl-0.9.7g in both ends ?
>
>  
>
Yes

>4 on what kernels is your setup based ?
>
>  
>
Stock vanilla kernel 2.4.30

>i have tested this config
>hostapd-0.4.1, wpa_supplicant-0.4.1
>madwifi-bsd-2005(0603)
>openssl-0.9.7g
>but no luck here :(
>
>  
>
What authentication are you trying?
WEP does not work in my case (with hostapd) but with ifconfig it works
WPA works with hostapd
Now I'm trying to go to EAP-TLS ...

What if done on suse9.0 system
Maybe you should move the ssl libs includedir to something else like I 
did (you cannot delete it
because ssh etc. needs this packages on the most distros so moving to 
test is ok)
Example:
   mv /usr/include /usr/include/openssl.delete
 cd /usr/lib;  mkdir /usr/lib/delete;  mv libss* libcrypto* delete

When the path of your installed of ssl i.e. mostly
/usr/local/lib
is in the /etc/ld.so.conf
file
ssh etc. works still with the new lib IF you have the same release 
number without suffix
i.e. 0.9.7a versus 0.9.7g (I think) ...


On debian I've removed debian ssl library package and have compiled ssl, 
ssh by myself.


NOTES: Have you tried to set radio card to one mode only i.e. for 
example only 802.11g
istead of auto on both sides?
If you are using a firewall and set the ip adress of the interface you 
must restart the firewall
so that the rules are reloaded so the network is ok (ping etc.) but of 
course nothing to to
with wireless auth.
Is using WPA-PSK how did you enter the pwd? I hade problems because the 
ssid is in the pw
of hostapd i.e.
wpa_passphrase="secret_pw" in hostapd.conf
and
psk="secret_pw" in wpa_supplicant conf
does not work!
I've generated a pw with
wpa_passphrase <ssid> <passphrase>
and used this at both ends
on hostapd now it is also psk="" stanza


I had problem if I modifed some stuff and the interface were up.
I start my hostapd like:

******************
DEVICE=ath0

ifconfig $DEVICE down
ifconfig $DEVICE 192.168.200.1
iwpriv $DEVICE mode 1
iwconfig $DEVICE channel 1
iwconfig $DEVICE mode Master
iwconfig $DEVICE

stopFirewall
startFirewall

# Use this if you want WPA-PSK authentification
hostapd -tdddd /etc/hostapd_WPA_PSK.conf
******************


Hope this helps a little bit.
Here ends my knowlege of all ...

Ok one more idea. Try first using WEP wihtout wpa_supplicant and hostapd 
so you know
that the madwifi driver is running ok at least at this level ...

Greetings

Beat


>Best Regards
>Lasse Jensen
>
>
>
>_______________________________________________
>HostAP mailing list
>HostAP at shmoo.com
>http://lists.shmoo.com/mailman/listinfo/hostap
>
>  
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20050604/950c89d5/attachment.htm 


More information about the HostAP mailing list