wpa_supplicant with madwifi, Netgear WAG511 and Netgear WGR614v1

Tino Keitel tino.keitel at gmx.de
Fri Jun 3 05:00:04 EDT 2005


Hi folks,                                                                       
                                                                                
I tried to get wpa_supplicant working with my Netgear WGA511 cardbus            
card and a Netgear WGR614v1 AP. The access point was flashed with new           
firmware which supports WPA, and it also works for a short time (1              
second), but then wpa_supplicant will start again, which leads to an            
endless loop. Between the loop cycles, the running ping will recieve a          
reply sometimes, so the configuration seems to be some sort of right.           
                                                                                
However, I don't know how I should read the wpa_supplicant messages to          
solve the retry loop problem. I started wpa_supplicant this way:                
                                                                                
wpa_supplicant -d -iath0 -Dmadwifi -c /etc/wpa_supplicant.conf                  
                                                                                
Here is my wpa_supplicant.conf:                                                 
                                                                                
eapol_version=1                                                                 
ap_scan=1                                                                       
fast_reauth=1                                                                   
                                                                                
network={                                                                       
        scan_ssid=1                                                             
        proto=WPA                                                               
        key_mgmt=WPA-PSK                                                        
        pairwise=CCMP TKIP                                                      
        group=CCMP TKIP WEP104 WEP40                                            
        ssid="SCORPIAP"                                                         
        psk="12345678"                                                          
}                                                                               
                                                                                
The wpa_supplicant output is attached. Apperently, the connection is up         
after the line "RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added", but          
only for ~1 second.                                                             
                                                                                
I use wpa_supplicant 0.4.0 on a Debian unstable system, together with           
the madfifi driver (BSD branch).                                                
                                                                                
Any hints?                                                                      
                                                                                
Regards,                                                                        
Tino                                                                            
-------------- next part --------------
Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 'madwifi'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
eapol_version=1
ap_scan=1
fast_reauth=1
Priority group 0
   id=0 ssid='SCORPIAP'
Initializing interface (2) 'ath0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
ioctl[SIOCSIWPMKSA]: Operation not supported
Own MAC address: 00:09:5b:68:33:ec
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_set_countermeasures: enabled=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Wireless event: cmd=0x8b06 len=8
State: DISCONNECTED -> SCANNING
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=8):
     53 43 4f 52 50 49 41 50                           SCORPIAP        
Wireless event: cmd=0x8b1a len=21
Wireless event: cmd=0x8b19 len=12
Received 700 bytes of scan results (3 BSSes)
Scan results: 3
Selecting BSS from priority group 0
0: 00:09:5b:52:d9:64 ssid='SCORPIAP' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
   selected
Trying to associate with 00:09:5b:52:d9:64 (SSID='SCORPIAP' freq=2447 MHz)
Cancelling scan request
Automatic auth_alg selection: 0x1
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Own WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
State: SCANNING -> ASSOCIATING
wpa_driver_madwifi_associate
Setting authentication timeout: 5 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b1a len=21
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:09:5b:52:d9:64
State: ASSOCIATING -> ASSOCIATED
Association event - clear replay counter
Associated to a new BSS: BSSID=00:09:5b:52:d9:64
No keys have been configured - skip key clearing
Associated with 00:09:5b:52:d9:64
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
RX EAPOL from 00:09:5b:52:d9:64
Setting authentication timeout: 10 sec 0 usec
IEEE 802.1X RX: version=1 type=3 length=95
  EAPOL-Key type=254
State: ASSOCIATED -> 4WAY_HANDSHAKE
WPA: RX message 1 of 4-Way Handshake from 00:09:5b:52:d9:64 (ver=1)
WPA: Renewed SNonce - hexdump(len=32): f5 73 e0 d1 11 e0 9e c3 68 4e b3 cf d7 16 8e 92 a9 53 d4 a8 d4 94 da e5 3f f8 75 aa d9 f0 89 4f
WPA: PMK - hexdump(len=32): [REMOVED]
WPA: PTK - hexdump(len=64): [REMOVED]
WPA: Sending EAPOL-Key 2/4
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:00:00:00:00:00
Setting scan request: 0 sec 100000 usec
Added BSSID 00:09:5b:52:d9:64 into blacklist
State: 4WAY_HANDSHAKE -> DISCONNECTED
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_del_key: keyidx=0
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:09:5b:52:d9:64
State: DISCONNECTED -> ASSOCIATED
Association event - clear replay counter
Associated to a new BSS: BSSID=00:09:5b:52:d9:64
No keys have been configured - skip key clearing
Associated with 00:09:5b:52:d9:64
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
RX EAPOL from 00:09:5b:52:d9:64
Setting authentication timeout: 10 sec 0 usec
IEEE 802.1X RX: version=1 type=3 length=95
  EAPOL-Key type=254
State: ASSOCIATED -> 4WAY_HANDSHAKE
WPA: RX message 1 of 4-Way Handshake from 00:09:5b:52:d9:64 (ver=1)
WPA: Renewed SNonce - hexdump(len=32): 22 a3 03 72 d1 cc 7e 28 45 11 41 b7 c3 f5 a8 19 08 14 98 91 78 e0 0b b6 db 44 cf 3f 82 5e 3f b8
WPA: PMK - hexdump(len=32): [REMOVED]
WPA: PTK - hexdump(len=64): [REMOVED]
WPA: Sending EAPOL-Key 2/4
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=12
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:00:00:00:00:00
Setting scan request: 0 sec 100000 usec
State: 4WAY_HANDSHAKE -> DISCONNECTED
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_del_key: keyidx=0
State: DISCONNECTED -> SCANNING
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=8):
     53 43 4f 52 50 49 41 50                           SCORPIAP        
Wireless event: cmd=0x8b1a len=21
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
Wireless event: cmd=0x8b19 len=12
Received 700 bytes of scan results (3 BSSes)
Scan results: 3
Selecting BSS from priority group 0
0: 00:09:5b:52:d9:64 ssid='SCORPIAP' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
   skip - blacklisted
1: 00:30:f1:fd:17:34 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
2: 00:04:0e:5f:6b:cf ssid='FRITZ!Box Fon WLAN 7050' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
No APs found - clear blacklist and try again
Removed BSSID 00:09:5b:52:d9:64 from blacklist (clear)
Selecting BSS from priority group 0
0: 00:09:5b:52:d9:64 ssid='SCORPIAP' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
   selected
Trying to associate with 00:09:5b:52:d9:64 (SSID='SCORPIAP' freq=2447 MHz)
Cancelling scan request
Automatic auth_alg selection: 0x1
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Own WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
State: SCANNING -> ASSOCIATING
wpa_driver_madwifi_associate
Setting authentication timeout: 5 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b1a len=21
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:09:5b:52:d9:64
State: ASSOCIATING -> ASSOCIATED
Association event - clear replay counter
Associated to a new BSS: BSSID=00:09:5b:52:d9:64
No keys have been configured - skip key clearing
Associated with 00:09:5b:52:d9:64
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
RX EAPOL from 00:09:5b:52:d9:64
Setting authentication timeout: 10 sec 0 usec
IEEE 802.1X RX: version=1 type=3 length=95
  EAPOL-Key type=254
State: ASSOCIATED -> 4WAY_HANDSHAKE
WPA: RX message 1 of 4-Way Handshake from 00:09:5b:52:d9:64 (ver=1)
WPA: Renewed SNonce - hexdump(len=32): 4b 4d d3 21 18 13 7b b8 be 8e b0 1f c2 78 ee 57 aa 07 77 b9 62 db 88 dd 4b 03 ab eb 68 6c e1 98
WPA: PMK - hexdump(len=32): [REMOVED]
WPA: PTK - hexdump(len=64): [REMOVED]
WPA: Sending EAPOL-Key 2/4
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:00:00:00:00:00
Setting scan request: 0 sec 100000 usec
Added BSSID 00:09:5b:52:d9:64 into blacklist
State: 4WAY_HANDSHAKE -> DISCONNECTED
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_del_key: keyidx=0
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:09:5b:52:d9:64
State: DISCONNECTED -> ASSOCIATED



More information about the HostAP mailing list