AR5112 card working with madwifi-bsd, hostapd-0.4.1, wpa_supplicant-0.4.1(and openssl-0.9.7g)

Victor Yeo yeosv at
Fri Jun 3 00:35:14 EDT 2005


Using Ar5213 card, I use hostapd-0.4.1 with latest madwifi bsd
branch, i can compile, after i run, i get these

What is the reason? In .config file, i set
CONFIG_DRIVER_MADWIFI=y and comment out
CONFIG_DRIVER_BSD. Could this be the reason?? Thanks
for any help.


# hostapd -d hostapd.conf
Configuration file: hostapd.conf
madwifi_set_iface_flags: dev_up=0
br0: port 1(ath0) entering disabled state
Using interface ath0 with hwaddr 00:0b:6b:34:88:d0 and
ssid 'MyWireless'
madwifi_set_ieee8021x: enabled=1
madwifi_configure_wpa: group key cipher=1
madwifi_configure_wpa: pairwise key ciphers=0x2
madwifi_configure_wpa: key management algorithms=0x2
madwifi_configure_wpa: rsn capabilities=0x0
madwifi_configure_wpa: enable WPA= 0x1
ioctl[IEEE80211_IOCTL_SETPARAM]: Invalid argument
ath0: DRIVER Error enabling WPA/802.1X!
IEEE 802.1X initialization failed.
rmdir[ctrl_interface]: No such file or directory
madwifi_set_privacy: enabled=0
madwifi_set_ieee8021x: enabled=0
madwifi_set_iface_flags: dev_up=0
Siow Vic
----- Original Message ----- 
From: "Beat Meier" <bmeier at>
To: <hostap at>
Sent: Friday, June 03, 2005 6:20 AM
Subject: AR5112 card working with madwifi-bsd,
hostapd-0.4.1,wpa_supplicant-0.4.1(and openssl-0.9.7g)

> Hello again
> Now it works ...
> "Configuration":
>   hostapd-0.4.1, wpa_supplicant-0.4.1
>   madwifi-bsd-20050530
>   openssl-0.9.7g
> Notes:
> hostapd-0.4.1
> I had to change the .config file of hostapd  so it can find the crypto
> lib of ssl.
> This seems strange but it is a real problem if you have 2 ssl
> installations!!
> In fact this could be a problem for many peobles
> because in wpa_supplicant you can configure which ssl should be used
> and in hostapd there is no comment ...
> In hostapd the crypto lib of the system (/usr/lib) was linked instead of
> the /usr/local/lib one.
> It should be the same note in defconfig in hostapd like in wpa_supplicant.
> # Uncomment following two lines and fix the paths if you have installed
> openssl
> # in non-default location
> #CFLAGS += -I/usr/local/openssl/include
> #LIBS += -L/usr/local/openssl/lib
> So I was able to use my NL-5354 MP PLUS ARIES2(F) 4G chipset AR5112
> at both end client and ap to connect with WPA-PSK.
> Only problem is that if the client disconnects the following errors from
> driver_madwifi.c of hostapd are logged:
> ioctl[IEE80211_IOCTL_DELKEY]: Invalied argument
> ioctl[IEE80211_IOCTL_DELKEY]: Invalied argument
> ioctl[IEE80211_IOCTL_SETMLME]: Invalied argument
> Any idea?
> Beat
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the HostAP mailing list