Problems with hostap-driver, wpa_supplicant and WPA-PSK

Urs Thuermann urs at isnogud.escape.de
Thu Jun 2 01:39:07 EDT 2005


Jouni Malinen <jkmaline at cc.hut.fi> writes:

> On Thu, Jun 02, 2005 at 06:19:10AM +0200, Urs Thuermann wrote:
> 
> > I have problems to set up wpa_supplicant to do WPA-PSK with the
> > following system:
> 
> >     wifi0: STA: id=0x1f v1.4.9
> 
> That firmware version is too old for WPA; at least 1.7.0 or newer is
> required. In other words, you will need to update the firmware in order
> to be able to use wpa_supplicant with that card and WPA-PSK.

Ah, thanx.  That's what I suspected, after sending my mail, I grepped
around in the source of hostap-driver, for ENOTSUPP in hostap-ioctl.c
and found

        case PRISM2_PARAM_WPA:
                local->wpa = value;
                if (local->sta_fw_ver < PRISM2_FW_VER(1,7,0))
                        ret = -EOPNOTSUPP;

and some more grepping showed that STA seems to be the fw version.

So, my next question is:  Is there a way to update the firmware under
linux?  The system is an embedded PC104 board and I'd rather not
disassemble it completely to pull the Prism2 card and insert it into
some Windows box.


urs



More information about the HostAP mailing list