Not able to change the bit rate

Pablo Osuna posuna at ehas.org
Wed Jul 20 15:34:51 EDT 2005


Hi all:

I am using a Senao NL-2511CD PLUS EXT2 PCMCIA Card with 0.3.7 hostap.
When I am using the card in Master Mode I am not able to change the rate
to any speed (1M, 2M, 5.5M) different from 11M. I tried to change
the /etc/network/interfaces file and use iwconfig wlan0 rate 1M, but
nothing happens.

See my configuration below:

At boot time

Loading modules: hostap_pci hostap_pci: 0.3.7 - 2005-02-12 (Jouni
Malinen <jkmaline at cc.hut.fi>)

cardmgr[128]: socket 1: Senao SL-2011CD/SL-2011CDPLUS
cardmgr[128]: executing: 'modprobe hostap'
cardmgr[128]: executing: 'modprobe hostap_cs'
hostap_cs: 0.3.7 - 2005-02-12 (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: Registered netdevice wifi0
hostap_cs: index 0x01: Vcc 3.3, irq 10, io 0x0100-0x013f
wifi0: NIC: id=0x800c v1.0.0
wifi0: PRI: id=0x15 v1.1.1
wifi0: STA: id=0x1f v1.5.6
cardmgr[128]: executing: './network start wlan0'
cardmgr[128]: + Debian network setup
cardmgr[128]: + /sbin/ifup wlan0
wlan0: updating basic rate set automatically to match with the new
supported rate set
cardmgr[128]: exiting

hostap_diag

pebble-ehas:~# hostap_diag wlan0
Host AP driver diagnostics information for 'wlan0'

NICID: id=0x800c v1.0.0 (PRISM II (2.5) PCMCIA (SST parallel flash))
PRIID: id=0x0015 v1.1.1
STAID: id=0x001f v1.5.6 (station firmware)


When I do iwconfig

pebble-ehas:~# iwconfig wlan0
Warning: Driver for device wlan0 recommend version 18 of Wireless
Extension,
but has been compiled with version 16, therefore some driver features
may not be available...

wlan0     IEEE 802.11b  ESSID:"hostap0"
          Mode:Master  Frequency:2.437 GHz  Access Point:
00:02:6F:05:4A:BA
          Bit Rate=11 Mb/s   Sensitivity=1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:13   Missed beacon:0


My /etc/network/interfaces file:

auto wlan0
iface wlan0 inet static
        address 192.168.89.1
        netmask 255.255.255.0
        broadcast 192.168.89.255
        wireless-rate 1M
        wireless-essid hostap0
        wireless-mode Master
        wireless-channel 6

I do not know if the Warning related to Wireless Extension I get with
iwconfig has something to do with this problem.
I also get with iwconfig the following message from time to time:

wlan0: updating basic rate set automatically to match with the new
supported rate set

I am using kernel 2.4.28.

Thanks and best regards:

Pablo




More information about the HostAP mailing list