T-mobile WPA

Harold Naparst hnaparst at gmail.com
Sun Jul 17 12:37:50 EDT 2005


I'm trying to connect to T-mobile's 802.1x network, but I'm obviously 
confused.
Here's my session: Also, I tried to reply to the thread in the mailing list, 
but I'm not
even sure how to do that...

# tail -12 /etc/wpa_supplicant.conf

network={
ssid="tmobile"
proto=WPA RSN
scan_ssid=1
key_mgmt=WPA-EAP IEEE8021X
pairwise=CCMP TKIP
eap=TTLS PEAP TLS
identity="me"
password="sesame"
priority=1
}

#iwconfig
lo no wireless extensions.

ath0 IEEE 802.11 ESSID:"tmobile" 
Mode:Managed Frequency:2.422 GHz Access Point: 00:00:00:00:00:00 
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3 
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:1959 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:1 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

# wpa_supplicant -c/etc/wpa_supplicant.conf -D madwifi -d -i ath0
Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 
'madwifi'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
Priority group 1
id=0 ssid='tmobile'
Initializing interface (2) 'ath0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
ioctl[SIOCSIWPMKSA]: Operation not supported
Own MAC address: 00:11:f5:2d:35:98
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_set_countermeasures: enabled=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=7):
74 6d 6f 62 69 6c 65 tmobile 
Wireless event: cmd=0x8b1a len=20
Wireless event: cmd=0x8b19 len=12
Received 202 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 1
0: 00:11:5c:81:b9:70 ssid='tmobile' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=12
Wireless event: cmd=0x8b19 len=12
Received 340 bytes of scan results (2 BSSes)
Scan results: 2
Selecting BSS from priority group 1
0: 00:11:5c:81:b9:70 ssid='tmobile' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
skip - no WPA/RSN IE
1: 00:0e:83:ed:91:af ssid='tmobile' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
skip - no WPA/RSN IE
No suitable AP found.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20050717/9b27c903/attachment.htm 


More information about the HostAP mailing list