Failed to get WPA/RSN information element

Toshiki Kaifu toshiki at confero24.com
Sat Jul 2 08:58:06 EDT 2005


Friends,

Having used hostapd with hostap-driver for a long and happy time, I have
been trying to get hostapd be the 802.11i/WPA authenticator for my
*802.11a/b/g Madwifi* AP (Linux 2.4.26).

Setup is:

Access Point: 
* AR5212 based CM9 a/b/g miniPCI 
  http://www.confero24.com/product_info.php?cPath=57&products_id=139
* Madwifi driver (snapshot of 20/06/2005)
* hostapd v0.3.7 (on Linux 2.4.26) - works perfect with hostap-driver

Client: 
* AR5210 based b/g PCMCIA
  http://www.wneweb.com.tw/wireless/products/cb9.htm
* Win-XP SP2
* Driver from Atheros (apparently version 3.3.0.156)

Basically the hostapd driver seems to startup cleanly, except for the
mysterious
>> l2_packet_receive - recv: Network is down, which apparently can be
ignored (according to a past list message by Jouni)

However I can't get the above PCMCIA to authenticate w/ the hostapd AP
due to folln error:

----
Deauthenticate all stations
l2_packet_receive - recv: Network is down
Wireless event: cmd=0x8b19 len=12
Wireless event: cmd=0x8c03 len=20
ath0: STA 00:0b:6b:20:0b:13 IEEE 802.11: associated
  New STA
*ioctl[unknown???]: Invalid argument*
*Failed to get WPA/RSN information element.*
Wireless event: cmd=0x8c03 len=20
----

Apparently the right WPA/RSN header is not being sent by the PCMCIA or
received by the Madwifi+hostapd.  This is with AP locked with iwpriv in
(mode=1) 11a/5GHz

Interestingly this same PCMCIA card works perfect with hostap + hostapd
setup under EAP-TLS, PEAP w/ TKIP.  11b/2.4GHz

Would anyone have a guess on why the *Failed to get WPA/RSN information
element* error?

Why does the Win-XP supplicant work with hostap+hostapd, but flunks on
madwifi+hostapd.

Thanks much for all your input.

Tosh Kaifu




More information about the HostAP mailing list