Fw: pae module from Gunter... problems

David Minodier forspam at david.wd107.tamaris.tm.fr
Tue Jan 25 09:24:36 EST 2005



> > If it works please send me your required modifications to pae for 2.6.
> > I will include this modifications in my tree.
>
>     Sure !
>
> Now, I dont understand something. I dont understand at which point
> af_packet.c and core/dev.c are called when I try to recompile pae.
> It seems that on my system, the layer2-patches I apply do absolutely
nothing
> to the pae module.
> Can you spot the #include that calls af_packet of dev.c for me please ?
> Do I have to recompile some bits of the kernel BEFORE I recompile pae ?
>
> By the way, to compile pae I use the following makefile. And I run make in
> the pae directory.
> Is that correct ?
> David.
>
> ---
> # Edit this path to match with your system (it should point to the root
> # directory of the Linux kernel source)
> ifndef KERNEL_PATH
> KERNEL_PATH=/usr/src/linux
> endif
> echo inclues=$(INCLUDES)
> DESTDIR=
>
> # if Rules.make exists in the kernel tree, we assume 2.4 style modules
> # if it doesn't assume 2.6 style
> OLDMAKE = $(wildcard $(KERNEL_PATH)/Rules.make)
>
> MSRC=pae
> MODULE_PAE=pae.o
> MODPATH_PAE=//lib/modules/2.6.8-1-686-smp/kernel/net/pae/
>
> VERFILE := $(KERNEL_PATH)/include/linux/version.h
> KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
>         then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES)
> $(CFLAGS) -E - | tail -1 | x
> args echo; \
>         else uname -r; fi)
> MODPATH := $(DESTDIR)/lib/modules/$(KERNELRELEASE)
> #MODPATH_PAE := $(MODPATH)/net
>
> ifeq (,$(OLDMAKE))
> all: 2.6
> else
> all: 2.4
> endif
> #echo ${MAKE}
> 2.4:
>         @if ! echo "$(KERNELRELEASE)" | grep -q "^2\.4"; then \
>                 echo "*** Can't build for 2.4 with a non-2.4 source!"; \
>                 exit 1; \
>         fi
>         echo "COMPILING FOR 2.4";
>         $(MAKE) -C $(KERNEL_PATH) SUBDIRS=`pwd`/modules modules
>         $(MAKE) install_all_info
>
> 2.6:
>         @if ! echo "$(KERNELRELEASE)" | grep -q "^2\.6" && \
>                 ! echo "$(KERNELRELEASE)" | grep -q "^2\.5"; then \
>                 echo "*** Can't build for 2.6 with a non-2.6 source!"; \
>                 exit 1; \
>         fi
>         echo "COMPILING FOR 2.6";
>         $(MAKE) -C $(KERNEL_PATH) SUBDIRS=`pwd`/modules \
>                 MODVERDIR=`pwd`/modules modules
>         $(MAKE) install_all_info
>
> clean:
>         rm -f modules/*.o
>         rm -f modules/*.ko
>
> install_all_info:
>         @echo "*** Become superuser and 'make install' to install the
> modules. ***"
>
> test:
>         $(MAKE) -C testing
>
> install:
>         @echo "Installing $(MODULE_PAE) to $(MODPATH_PAE)"
>         mkdir -p $(MODPATH_PAE)
>         cp -f modules/$(MODULE_PAE) $(MODPATH_PAE)
>         cp -f modules/pae.ko $(MODPATH_PAE)
>
>
>
>
>
>




More information about the HostAP mailing list