pae module from Gunter... problems

David Minodier forspam at david.wd107.tamaris.tm.fr
Tue Jan 25 05:58:48 EST 2005


> Support for 2.6 is not implemented yet. I will work on it. At the
> moment only 2.4 is supported.

OK. I have managed to compile the pae module and insert it into the kernel :
authenticatorII:/lib/modules/2.6.8-1-686-smp/kernel/net/pae# lsmod
Module                  Size  Used by
<SNIP>
pae                    12040  0 [unsafe]
</SNIP>

When patched-hostap runs I get :
authenticatorII:/lib/modules/2.6.8-1-686-smp/kernel/net/pae# lsmod|more
Module                  Size  Used by
<SNIP>
pae                    12040  1 [unsafe]
</SNIP>
Which means that the pae module is used by hostap right ?

Can anyone explain why I get [unsafe] instead of hostapd in the lsmod line ?

And.... unfortunately, when hostapd runs and when the supplicant is not
authenticated, it can send packets anyway.
Boooohhhh.... But yes, I'm still in a 2.6.8 kernel debian configuration and
yes, it's unsupported. So...

Subsidiary question. Can the client interface of the authenticator have an
IP address or has it got to be bridged with the WAN interface of the
authenticator ? (the authenticator being the machine running hostapd).

Many thanks !
David.




More information about the HostAP mailing list