ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument

Marc Dirix marc at electronics-design.nl
Sun Feb 20 07:21:19 EST 2005


> 
> Maybe you have the same problem I'm having.
> I just assume that you are trying to use hostap(d) on a
> DEC Alpha AXP (64bit, little-endian) architecture.

Sun sparc, that's also 64bit. I'm currently investing some time
in getting wireless-tools working. (it segfaults on my system with
hostap-driver). The problem seems to disappear when I add a printf, or
lower optimisation. Which makes me think of timing problems. 
When it doesn't segfaul, I kan make settings with the programm but
one, the setting of the ESSID doesn't work at all.


> 
> I have a Netgear MA-311 (f/w 1.8.0) and it is working fine on
> a HP PA-RISC workstation running a 32bit (big-endian) linux-2.6.10.
Formerlerly I used the same card, in an i386 system with same kernel,
and same setup. After replacing the server with a Sun Ultra10 it stopped
working.

> However when I'm using a 64bit kernel I'm getting similar/same
> errors as you when trying to use the userspace utilities (hostapd,
> prism2_param, ...). But the hostap kernel module is working fine.
> (N.B.: Linux/PA-RISC currently only supports/uses 32bit userland).
I'm not sure, how this is done in Sparc-Linux.
> 
> IMHO this might indicate that there are some ioctl() issues in hostap,
> eg. when the (32bit) userspace utilities try to connect.to the (64bit)
> hostap kernel module.
Yes, I also think it might be time-related.

We could try (as you describe in your next mail) to get back to the
revision which was working, and trace code alteration.

/Marc

Pffoew, thought I was the only one having this problem.....




More information about the HostAP mailing list