hostap_driver-0.3.7 and wireless-tools

Jar jar at pcuf.fi
Sat Feb 19 19:31:31 EST 2005


Jar wrote:

> Jouni Malinen wrote:
> 
>> On Sat, Feb 19, 2005 at 10:54:11PM +0000, Jar wrote:
>>
>>
>>> OK, but I get those extra lines every time when scripts are running. 
>>> Maybe I have to use old driver and wait until WE18 is supported in 
>>> kernel and wireless-tools. Or is there another way to get 
>>> wireless-tools happy?
>>
>>
>>
>> Well, those scripts could be be modified to redirect stderr to
>> /dev/null.. Alternatively, you can patch either wireless-tools to ignore
>> this or the driver to report WE17.
> 
> 
> Hmmm..how I need to change the driver code that it reports WE17?

In hostap_ioctl.c
-range->we_version_source = 18;
+range->we_version_source = 17;

Would this change be enough to change the driver to report WE17 ?

---
Best Regards, Jar




More information about the HostAP mailing list