hostap/iwconfig on Sun ultra10

Marc Dirix marc at electronics-design.nl
Tue Feb 15 19:58:48 EST 2005


I recently (as in today) tradet a i386-based server for a sun Utra10.
To make a smooth switch I installed debian linux on this sun, and
downloaded the stable version of hostap-driver and hostapd.

The hostap-drivers inserted smoothly, and I've got the wlan0 and wifi0
interfaces up, and communication with my laptop is possible.

(I don't know why but my card always generates these two
interfaces both having same mac, and both respond the same on command,
but this was also in the old setup present)

However, the hostapd is yet another thing. It returns this message:

	alpha:/usr/src/hostapd-0.3.7# hostapd /etc/hostapd/hostapd.conf
	Configuration file: /etc/hostapd/hostapd.conf
	ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
	Could not enable hostapd mode for interface wlan0
	hostap driver initialization failed.
	rmdir[ctrl_interface]: Bad address

The same version, 0.3.7 worked on the i386-system.

Furthermore, whenn I use "iwconfig" I get a segfault:

	alpha:/usr/src/wireless_tools.27# ./iwconfig
	eth0      no wireless extensions.

	lo        no wireless extensions.

	eth1      no wireless extensions.

	sit0      no wireless extensions.

	ip6tnl0   no wireless extensions.

	Segmentation fault
	alpha:/usr/src/wireless_tools.27# 

Any ideas? Or need more feedback?

Are there more people trying to run hostap on linux-sparc?

Although I would like to get hostapd back up and running, it isn't
mandatory since I set up a mac-specfic iptables ruleset (and
macaddress-spoofing is not commen in my neighbourhood ;).

/Marc



More information about the HostAP mailing list