Problems with WPA-PSK and madwifi driver

Jouni Malinen jkmaline at cc.hut.fi
Thu Feb 10 23:41:56 EST 2005


On Thu, Feb 10, 2005 at 11:00:07AM -0800, Michael Reilly wrote:

> Atheros based cards have not worked with madwifi and wpa_supplicant for me 
> for several months.  I have been forced to purchased a driverloader license 
> which does work with wpa_supplicant and my Atheros based cards

madwifi + wpa_supplicant has worked fine in my tests during the last
months and number of different APs and different security policies etc.
This has been with numerous CVS versions of both madwifi and
wpa_supplicant.

> I also tried ndisdriver but it wouldn't even find the APs (Cisco, Linksys, 
> D-Link) then.

I could repeat my comment above for ndiswrapper + wpa_supplicant case.
However, in this case there have been a bit more variance based on which
NDIS driver version was used.


In other words, there a lots of known cases where both of these
combinations work fine. In order to resolve possibly remaining issues,
more detailed reports are needed. These should include exact description
of the used configuration (both the AP and client sides) and debug logs
from all the possible sources (AP, authentication server, client (both
driver and wpa_supplicant debug).

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list