Problems with WPA-PSK and madwifi driver

Gilbert Mendoza linuxcruiser at yahoo.com
Thu Feb 10 18:51:35 EST 2005


--- Michael Reilly <michaelr at cisco.com> wrote:

> Atheros based cards have not worked with madwifi and wpa_supplicant
> for me for 
> several months.  I have been forced to purchased a driverloader
> license which 
> does work with wpa_supplicant and my Atheros based cards
> 
> I also tried ndisdriver but it wouldn't even find the APs (Cisco,
> Linksys, 
> D-Link) then.
> 



Madwifi CVS + wpa_supplicant 0.3.6 works great for me.  I had no need
for ndiswrapper in this case.

I currently use a couple different Atheros Chipset cards:
Cisco A/B/G Card (AIR-CB21AG-A-K9)
Proxim GOLD ORiNOCO 11b/g (8470-FC)

I currently switch between a few wireless security configurations
without problems:

1. WPA+PSK TKIP (Linksys WRT54G Access point), non-broadcasted SSID.

2. Enterprise WPA, EAP-PEAP, MSCHAPv2, Cisco Aironet 1200 AP's, Cisco
ACS servers v3.2 and v3.3, non-broadcasted SSID's.

3. Enterprise WPA, EAP-PEAP, EAP-GTC, Cisco Aironet 1200 AP's, Cisco
ACS servers v3.2 and v3.3, non-broadcasted SSID's.

=====
- Gilbert Mendoza
- PGP Key ID: 7987FCA8

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



More information about the HostAP mailing list