Error during hostapd compilation. (Jim Cromie)

Ged Haywood ged at jubileegroup.co.uk
Wed Feb 2 03:49:26 EST 2005


Hi there,

On Wed, 2 Feb 2005 Jim Cromie wrote:

> name wrote:
>
> > I am getting following error when building hostspd.
> > In file included from ieee802_1x.c:34:
> > md5.h:6:25: openssl/md5.h: No such file or directory
>
> U probly need something like this rpm: openssl-devel-0.9.7a-40

Yes, you probably need to install the sources (at least some headers).
For security reasons at least you should also take care to keep your
version of OpenSSL up to date.  Version 0.9.7a is rather old, take a
look at http://www.openssl.org/ which says

"25-oct-2004:
OpenSSL 0.9.7e is now available, including important bugfixes"

You can download the OpenSSL source from that site.

If you need to convert source tarballs to RPMs, Checkinstall is reputed
to be able to do it: http://asic-linux.com.mx/~izto/checkinstall/.  I do
not use RPMs if I can avoid it so I can't vouch for it personally, but it
looks to be very well presented and there is a good report from a user at
http://www.webservertalk.com/archive200-2004-5-235866.html

HTH

73,
Ged.



More information about the HostAP mailing list