Two Senao PCMCIA cards in Mips AMD Alchemy board

Josh Green jgreen at users.sourceforge.net
Wed Feb 2 03:40:29 EST 2005


Hello, I'm attempting to turn an embedded AMD Alchemy board into a
wireless access point and bridge between a point to point link.  For
this I am using 2 Senao 200mW 802.11b cards (the one with 2 antenna
connectors).  I'm using a cross compiler tool chain (gcc 3.4.3) to build
the kernel modules.  When I start pcmcia (cardmgr) with both cards
inserted I get the following output:

Linux Kernel Card Services
  options:  none
hostap_cs: 0.2.6 - 2004-12-25 (Jouni Malinen <removed email address>)
hostap_cs: Registered netdevice wifi0
hostap_cs: index 0x01: Vcc 3.3, irq 34, io 0xc0000000-0xc000003f
wifi0: NIC: id=0x800c v1.0.0
wifi0: PRI: id=0x15 v1.1.0
wifi0: STA: id=0x1f v1.4.9
0.0: RequestIO: Configuration locked    <--- Second card causes this
0.0: GetNextTuple: No more items
ds: unable to create instance of 'hostap_cs'!


When this happens, one card will function correctly (wlan0 available,
etc) but the other one will not (no wlan1).  I can get things to work
sometimes if I start PCMCIA then insert one card, wait a bit and then
the other.  I've posted this to the Linux MIPS list also, in case its a
MIPS related problem, but I thought I'd check here as well.
I noticed in the hostap_cs.c file this:

/* This reserves IO space but doesn't actually enable it */
CFG_CHECK2(RequestIO,
	   pcmcia_request_io(link->handle, &link->io));

Which is the call that is printing that error message (for the second
device).  The handle pointer is the same as the one passed in the first
call.


Here is an additional error that I receive sometimes (no specific way to
cause it that I have discovered yet).

Badness in local_bh_enable at kernel/softirq.c:140
Call Trace:
 [<802482c4>] skb_clone+0x24/0x374
 [<8012c3c8>] local_bh_enable+0x74/0x9c
 [<80251048>] dev_queue_xmit+0x310/0x374
 [<80249884>] kfree_skbmem+0x14/0x30
 [<c0064438>] hostap_data_start_xmit+0x80c/0xac4 [hostap]
 [<8024866c>] alloc_skb+0x58/0xf4
 [<802a1240>] arp_constructor+0x28/0x274
 [<802a0000>] udp_rcv+0x368/0x938
 [<80250e14>] dev_queue_xmit+0xdc/0x374
 [<80360000>] ip_auto_config_setup+0x64/0x240
 [<802a2944>] arp_process+0x7f8/0xa6c
 [<c0062b20>] hostap_80211_rx+0x1034/0x1f04 [hostap]
 [<80251978>] netif_receive_skb+0x1c4/0x3d4
 [<80251978>] netif_receive_skb+0x1c4/0x3d4
 [<80251c98>] process_backlog+0x110/0x2f0
 [<80250000>] dev_change_name+0x34/0x2ec
 [<c003f96c>] hostap_rx_tasklet+0x228/0x2bc [hostap_cs]
 [<80251f44>] net_rx_action+0xcc/0x294
 [<8012c818>] tasklet_action+0xc4/0x194
 [<801479f4>] handle_IRQ_event+0x7c/0x134
 [<8012c1dc>] __do_softirq+0x8c/0x14c
 [<80147c40>] __do_IRQ+0x194/0x1b4
 [<80360000>] ip_auto_config_setup+0x64/0x240
 [<80360000>] ip_auto_config_setup+0x64/0x240
 [<8012c328>] do_softirq+0x8c/0xb8
 [<80360000>] ip_auto_config_setup+0x64/0x240
 [<80100e2c>] au1000_IRQ+0x16c/0x1a0
 [<80360000>] ip_auto_config_setup+0x64/0x240
 [<80104a90>] cpu_idle+0x48/0x50
 [<80104a60>] cpu_idle+0x18/0x50
 [<801f4980>] idr_cache_ctor+0x0/0xc
 [<80360000>] ip_auto_config_setup+0x64/0x240
 [<803437ac>] start_kernel+0x200/0x2c0
 [<803430fc>] unknown_bootoption+0x0/0x310


If anyone has any ideas on resolving these issues or can confirm them
I'd appreciate the info.  Best regards,
	Josh Green

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20050202/e1783e29/attachment.pgp 


More information about the HostAP mailing list