AW: Failed to set encryption with wpa_supplicant failed to connectAP

Haydar Tekir haydar.tekir at gmx.net
Sat Dec 31 07:57:41 EST 2005


...bingo the tip with the "ap_scan=1" worked fine;-)
It is kind of strange, why the wext is not working with the hidden
BSSID. Anyway I've implemented a script to start wpa_supplicant on boot
time.
I also found out, that you must leave the wpa-psk, password options of
the wlan card empty,
so otherwise the wpa_supplicant does not work propper too.

Anyway, many thanks for your kind assistance in this case

Rgds

haydar

-----Ursprüngliche Nachricht-----
Von: hostap-bounces+haydar.tekir=gmx.net at shmoo.com
[mailto:hostap-bounces+haydar.tekir=gmx.net at shmoo.com] Im Auftrag von
Bryan Kadzban
Gesendet: Freitag, 30. Dezember 2005 19:04
An: hostap at shmoo.com
Betreff: Re: Failed to set encryption with wpa_supplicant failed to
connectAP


Haydar Tekir wrote:
> ap_scan=2

Have you tried anything else for ap_scan?  I believe a lot of drivers
don't support it; I'm fairly sure that only the ndiswrapper or Windows
NDIS drivers are supposed to work with it.  I believe most of the
testing on Linux happens with ap_scan=1 (or whichever value is the
default).

> RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
> State: DISCONNECTED -> SCANNING
> Trying to associate with SSID 'mesiah'
> <...>
> State: SCANNING -> ASSOCIATING
> <...>
> Wireless event: cmd=0x8b06 len=8
> Wireless event: cmd=0x8b1a len=19

These two events (from some cursory Google research) are "set frequency"
and "set SSID".  No surprise there -- that's what ap_scan=2 does.  It
runs through each of the network blocks in the config file, and tries to
associate with each, in turn...

> State: ASSOCIATING -> DISCONNECTED

But "something" (not sure what) comes back and disconnects.

I'm thinking the driver (and when I say "driver", I don't really know if
the problem is with the -Dwext code inside wpa_supplicant, or the Linux
wireless extensions interface inside the ipw2100 kernel module) doesn't
support ap_scan=2.  If you don't need =2, try ap_scan=1.




More information about the HostAP mailing list