hostapd/wpa_supplicant - new development release v0.5.0

John H. mistamaila at gmail.com
Sun Dec 25 16:57:45 EST 2005


i just upgraded firmware on router, changed ap_scan to 1, and ran the
supplicant, and i get this


./wpa_supplicant -w -dd -D zydas -i wlan0 -c /etc/wpa_supplicant.conf
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0
eapol_version=1
ap_scan=1
Line: 191 - start of a new network block
SSID - hexdump_ascii(len=12):
     4e 65 74 77 6f 72 6b 34 48 6f 6d 65               Network4Home
pairwise: 0x8
PSK - hexdump(len=32): ea c6 8b 53 41 90 ea 70 f2 80 b4 ab 91 58 d1 14
a6 bb db 58 22 df 20 50 68 06 17 62 83 7e 1f a8
group: 0x8
key_mgmt: 0x2
proto: 0x1
Priority group 0
   id=0 ssid='Network4Home'
Using existing control interface directory.
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Get own MAC [1211]00:12:0e:11:b7:42
wpa_driver_zydas_set_wpa: enabled=1
wpa_driver_zydas_set_key: alg=NONE key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_key: alg=NONE key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_key: alg=NONE key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_key: alg=NONE key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_countermeasures: enabled=0
wpa_driver_zydas_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Starting AP scan (broadcast SSID)



it's stuck there, ifconfig and iwconfig, etc, no longer work, they
just lock up on running.


On 12/24/05, John H. <mistamaila at gmail.com> wrote:
> well, i am using the version from zydas, that i linked earlier, as
> that is the only one that seems to work:(
> If you can tell me what to ask them, i will email them.
>
> i can use the AP through wpa fine in XP.  It's a linksys wrt54gs
> router, and the SSID is viewable in XP, so it should be being
> broadcast, as i did not hide it?  i am running kernel 2.6.14.2 on fc4
> machine.
>
> router is set to broadcast ssid, Network4Home is SSID, using WPA-PSK,
> TKIP, wireless mac filter is disabled, and advanced wireless options
> are all default.
>
> On 12/24/05, Jouni Malinen <jkmaline at cc.hut.fi> wrote:
> > On Sat, Dec 24, 2005 at 10:13:13PM -0600, John H. wrote:
> > > Can't zydas themselves grant permission?
> > > jc at zydas.com.tw
> > > rhsieh at zydas.com.tw
> > > either of those may work.
> >
> > Sure. Would you be interested in trying to ask them for permission and
> > then reporting here what happened? Or even better, get them to mail
> > me or the list with permission to use the version.
> >
> > > i'd be happy with 1.2.0 if it would just stop locking up when i use
> > > ap_scan=1 or ap_scan=2.
> >
> > Please do not use version "1.2.0" on this mailing list. I have no idea
> > what that version number means, but it has nothing to do with the main
> > wpa_supplicant distribution. What exactly do you mean with "locking up"?
> >
> > > 0: 00:0f:66:53:3e:24 ssid='' wpa_ie_len=0 rsn_ie_len=0
> > >    skip - no WPA/RSN IE
> > > No suitable AP found.
> >
> > This looks like either incorrect parsing of scan results (which may be
> > happening if you are running new enough kernel with an old version of
> > wpa_supplicant) or an AP that has disabled SSID broadcasting and is not
> > configurdd for using WPA/WPA2. Please describe the expected behavior
> > (i.e., is that MAC address correct and how was the AP configured).
> >
> > --
> > Jouni Malinen                                            PGP id EFC895FA
> > _______________________________________________
> > HostAP mailing list
> > HostAP at shmoo.com
> > http://lists.shmoo.com/mailman/listinfo/hostap
> >
>



More information about the HostAP mailing list