problems with zd1211 and wpa

John H. mistamaila at gmail.com
Fri Dec 23 05:07:08 EST 2005


---------- Forwarded message ----------
From: John H. <mistamaila at gmail.com>
Date: Dec 23, 2005 4:05 AM
Subject: Re: problems with zd1211 and wpa
To: zd1211-devs at lists.sourceforge.net


here is what happens with ap_scan=1 and running wpa_supplicant in
debug mode.  eventually, it locks up things, as you can see here.  the
only way to prevent lock up seems to be ap_Scan=0.  my ssid, as you
can see, is network4home, and it works fine in XP.

proto: 0x1
Priority group 0
   id=0 ssid='Network4Home'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Get own MAC [1211]00:12:0e:11:b7:42
wpa_driver_zydas_set_wpa: enabled=1
wpa_driver_zydas_set_key: alg=NONE key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_key: alg=NONE key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_key: alg=NONE key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_key: alg=NONE key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_zydas_set_countermeasures: enabled=0
wpa_driver_zydas_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
l2_packet_receive - recv: Network is down
Starting AP scan (broadcast SSID)
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 0
No suitable AP found.
Setting scan request: 5 sec 0 usec
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
Starting AP scan (broadcast SSID)
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 0
No suitable AP found.
Setting scan request: 5 sec 0 usec
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
Starting AP scan (broadcast SSID)
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 0
No suitable AP found.
Setting scan request: 5 sec 0 usec
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
Starting AP scan (broadcast SSID)
wlan0: Tx timed out, trying reset


wlan0: Tx timed out, trying reset



More information about the HostAP mailing list