signal quality, prism firmware, WPA

Tony Espy espy at
Mon Dec 12 18:54:14 EST 2005

Tony Espy wrote:
> I've reported this problem multiple times.  We also are using a PCMCIA 
> based Prism card.  I reported a patch for v0.3.9 of the driver awhile 
> back ( see below ).
> What I found was that the method hostap_join_ap() in hostap_ioctl.c 
> could end up passing a channel number of 0 to the firmware when it sent 
> a JOINREQUEST.  This was due to the fact that there were two seperate 
> arrays that could hold scan results, one called scan_results and one 
> called hostscan_results.

oops, i left a bit out...  with a new version of firmware, the driver 
always issues a HOSTSCAN, however the hostap_join_ap() method only 
walked thru the last_scan_results array which isn't used when a HOSTSCAN 
is done.  this meant the channel value was set to 0 on the JOINREQUEST.

note - the driver separately sets the channel, so the join will work, 
and data can be transferred, however as you've seen, signal strength 
reporting is broken.

Tony Espy
Pepper Computer

p.s. this should only be a 0.3.x problem as Jouni re-worked the way scan 
results are handled in the 0.4.x branch.

> For details and a copy of the patch we're currently running with see my 
> original post at:
> Let me know if you have any questions.
> Tony Espy
> Pepper Computer
> Paul Fox wrote:
>>hi -- i have a very repeatable problem i'm hoping someone here
>>can shed light on.
>>we're using PCMCIA cards based on the (now Intersil) Prism 2.5
>>chipset.  the cards are the Engenius (or Senao) NL-2511CD Plus,
>>like this:
>>as shipped, the cards we've gotten have firmware version 1.4.9,
>>which works just fine with WEP and the hostap drivers (version
>>0.3.9).  (we're not using hostapd -- we're just a station.)
>>however, we need WPA.  so i've upgraded some of our cards to
>>1.8.4.  (i've also tried intermediate versions, like 1.7.1, with
>>similar results.)  device identification currently looks like this:
>>    wifi0: NIC: id=0x800c v1.0.0
>>    wifi0: PRI: id=0x15 v1.1.1
>>    wifi0: STA: id=0x1f v1.8.4
>>when using WEP, everything still works fine, just as it did with 1.4.9.
>>however, when using WPA, the signal quality, strength, and noise
>>values all report bogus results.  signal quality is consistently
>>reported as 0, strength and noise report as a constant non-zero
>>value.  (i've verified this at a low level with driver printks, so
>>specific tool versions can be eliminated i think.)
>>there are two RID values for fetching these parameters -- one is
>>"raw" (HFA384X_RID_COMMSQUALITY, or 0xFD43) and the other is
>>newer, with results in dbm (HFA384X_RID_DBMCOMMSQUALITY, or
>>0xFD51).  normally with newer firmware the latter RID command
>>is used.  i modified the driver to force the older api, and
>>the results are the same -- quality is consistently 0, strength
>>and noise are unvarying non-zero numbers.
>>i have (legitimate) access to the prism driver programmers
>>manual, and from what i can tell, the hostap driver is using the
>>API correctly.  (and, indeed, it seems to work just fine when WPA
>>isn't involved.)
>>testing the 1.8.4 firmware in a windows laptop shows that, as
>>expected, quality and strength values are somehow available,
>>since the prism driver and status utility report the values
>>without complaining.
>>has anyone else seen this behavior?  i've found references to
>>similar problems in the list archives, but the messages were
>>almost two years old...
>>many thanks in advance.
>>(so far the only oddness i've noticed is what i've detailed here. 
>>are there other stats i should be checking in particular to see
>>if they're also not reported correctly?)
>> paul fox, pgf at
>>HostAP mailing list
>>HostAP at
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the HostAP mailing list