wpa_supplicant-EAP-TTLS-PAP issue

Nicolas Will nico at rdo.homelinux.org
Fri Dec 2 16:51:17 EST 2005


Nicolas Will wrote:

>Nicolas Will wrote:
>
>  
>
>>Hi,
>>
>>I'm trying to use wireless provided by my corporate network. It uses
>>WPA, EAP-TTLS, PAP phase 2 auth, TKIP, WEP104... THE AP hides its SSID.
>>
>>Here is what I run:
>>
>>Distro:      Ubuntu Breezy 5.10
>>Kernel:      Ubuntu's 2.6.12-10 with no patching of my own
>>wi-fi card   AT&T pc card on madwifi
>>madwifi      ath_hal 0.9.14.9 - ath_pci 0.9.6.0
>>wpasupplicant   0.4.5-0ubuntu1
>>Access point      Cisco 1220
>>RADIUS server   Funk wotking with an LDAP directory in the back-end
>>
>>Command line used:
>>
>>$ sudo wpa_supplicant -i ath0 -c /etc/wpa_supplicant.conf -D madwifi -dd
>>
>>Here is a directory with the conf file and an output of the command line:
>>
>>http://rdo.homelinux.org/~will/wpasupplicant/
>>
>>It looks like things go somehow well, and then it goes into a loop,
>>re-scanning, etc...
>>
>>I'm trying to get my network guys to do some log tracing on the AP and
>>on the RADIUS server.
>>
>>I would be thankful for any help provided.
>>
>>    
>>
>
>
>
>I added my CA's cert in the conf file.
>
>I see OpenSSL lines showing that it is recognized properly, same for my
>RADIUS server's cert.
>
>    TLS: tls_verify_cb - preverify_ok=1 err=0 (ok) depth=1
>    buf='/C=AN/O=slb/OU=role/CN=Schlumberger Aubade - Certificate Authority'
>    TLS: tls_verify_cb - preverify_ok=1 err=0 (ok) depth=0
>    buf='/C=an/O=slb/OU=service/CN=radius1.houston.nam.slb.com'
>
>BTW, my libssl is 0.9.7g-Ubuntu1.1
>


More info....

The Access Point tells me AUTH FAILURE

The RADIUS server.... hmmm..... I hate Funk... All logs end up in the
same massive text file, with no session info... so all authentications a
mixed-up.... I'll try to grab a raw file and make some sense out of it.

Nico



More information about the HostAP mailing list