Re-post: Invalid module format and version magic complaints

Jouni Malinen jkmaline at cc.hut.fi
Sun Apr 17 20:44:35 EDT 2005


On Sun, Apr 17, 2005 at 03:31:49PM -0700, Randall Ross wrote:

> Pursuing the theory that the compiler mismatch is causing the failure, 
> is there an elegant workaround? Is there a way to disable the gcc 
> version check? I would think that gcc-3.4 is a superset of gcc-3.2 and 
> therefore should be backwards compatible...

There is a reason for that verification.. Something may have changed in
the way gcc aligns variables, uses function parameters, etc. If anything
goes wrong, no one is likely willing to help before both the kernel and
all modules are compiled with the same compiler version. In other words,
the only reasonable fix for this is to either recompile the kernel or
compile the driver with the same gcc version that was used to build the
kernel.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list