WDS link problem: ping only

michael schatz thevedado at yahoo.com
Sun Oct 31 23:05:18 EST 2004


Hi-
I've established a WDS static link between two APs running hostAP (call
them AP:A and AP:B) under RedHat 9.0. AP:A and all wireless devices that
associate with it have full access to the internet (ping, DNS, web
browsing, ssh, etc). AP:B also has full access to the internet, but
all wireless devices associated with AP:B can only ping (only by using IP
addresses)....nothing else works( no DNS, no ssh, no web
browsing, etc). below
i give the architecture and the scripts on both APs (/etc/rc.local)
that i use to set up the WDS link with ipforwarding and routing. could
someone suggest what i'm missing in configuring the forwarding/routing
of AP:B's devices?


Thanks!

Mike

> > INTERNET via router (192.168.0.1)
> > |
> > |
> > eth0 (192.168.0.7): AP-A :wlan0 (10.1.2.1) -- 
> > |
> > |
> > |10.1.2.254/30
> > WDS
> > |10.1.2.253/30
> > |
> > AP-B:wlan0 (10.1.3.1)---
>
>
********AP:A initialization script********
#!/bin/sh
#

touch /var/lock/subsys/local
echo "Local wlan0 config. stuff"
/sbin/iwconfig wlan0 channel 1 ESSID "Vedado" txpower 15

echo "setup WDS static link"
#MAC address below from AP on other end of the link
iwpriv wlan0 wds_add BB:BB:BB:BB:BB:BB
ip addr add 10.1.2.254/30 broadcast 10.1.2.255 dev wlan0wds0
ip link set wlan0wds0 up

echo "Enabling IP Masquerading"
/sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
echo "1" >/proc/sys/net/ipv4/ip_forward


********AP:B initialization script********

#!/bin/sh
#
touch /var/lock/subsys/local
echo "Local wlan0 config. stuff"
/sbin/iwconfig wlan0 channel 1 ESSID "Vedado" txpower 23

echo "set up WDS static link"
#MAC address below from other end of link
iwpriv wlan0 wds_add AA:AA:AA:AA:AA:AA

ip addr add 10.1.2.253/30 broadcast 10.1.2.255 dev wlan0wds0
ip link set wlan0wds0 up

echo "Enabling IP Masquerading"
/sbin/iptables -t nat -A POSTROUTING -o wlan0wds0 -j MASQUERADE
/sbin/route add -net default gw 10.1.2.254 metric 1

echo "1" >/proc/sys/net/ipv4/ip_forward






		
---------------------------------
Do you Yahoo!?
Read only the mail you want - Yahoo! Mail SpamGuard.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20041031/f0870881/attachment.htm 


More information about the HostAP mailing list